aboutsummaryrefslogtreecommitdiffstats
path: root/games/quackle
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-12-24 06:52:00 +0800
committerpawel <pawel@FreeBSD.org>2014-12-24 06:52:00 +0800
commit136ca58cc67af0b1a4de6ed19b6c3e28285e40ef (patch)
treecb39f408576335ad05e6c9311d84cf9dccd18a8b /games/quackle
parent80b0217764144b1ce426ea6bc721c78d04630726 (diff)
downloadfreebsd-ports-gnome-136ca58cc67af0b1a4de6ed19b6c3e28285e40ef.tar.gz
freebsd-ports-gnome-136ca58cc67af0b1a4de6ed19b6c3e28285e40ef.tar.zst
freebsd-ports-gnome-136ca58cc67af0b1a4de6ed19b6c3e28285e40ef.zip
- Update to version 0.98, now hosted on GitHub
- LICENSE is GPLv3 now - Builds fine with clang Changelog: Norwegian dictionary! (Choose "norwegian" alphabet and "norwegian" lexicon. Hat tip Per Steinar Moen.) Polish dictionary! (Choose "polish" alphabet and "osps" lexicon. Hat tip Adam Klimont and Polish Federation of Scrabble.) Color themes! Easier board configuration based on the mathematics of symmetry! Better behavior with international keyboards. Fixes for OS X Mavericks. (And a lot of other code cleanups by Matt Liberty.)
Diffstat (limited to 'games/quackle')
-rw-r--r--games/quackle/Makefile35
-rw-r--r--games/quackle/distinfo4
-rw-r--r--games/quackle/pkg-plist36
3 files changed, 27 insertions, 48 deletions
diff --git a/games/quackle/Makefile b/games/quackle/Makefile
index ba17f991c537..9322e43f7ccd 100644
--- a/games/quackle/Makefile
+++ b/games/quackle/Makefile
@@ -2,38 +2,31 @@
# $FreeBSD$
PORTNAME= quackle
-PORTVERSION= 0.97
-PORTREVISION= 2
-DISTVERSIONSUFFIX= -source
+PORTVERSION= 0.98
CATEGORIES= games
-MASTER_SITES= http://people.csail.mit.edu/jasonkb/quackle/downloads/%SUBDIR%/
-MASTER_SITE_SUBDIR= ${PORTNAME}-${PORTVERSION}
MAINTAINER= pawel@FreeBSD.org
COMMENT= Scrabble-like word game utilizing Qt4
-LICENSE= GPLv2 GPLv3
-LICENSE_COMB= dual
+LICENSE= GPLv3
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-BUILD_WRKSRC= ${WRKSRC}/quacker
+USE_GITHUB= yes
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= 7c118f2
USES= gmake qmake
-USE_GCC= any
USE_QT4= gui moc_build
-DESKTOP_ENTRIES="Quackle" "${COMMENT}" "" "quackle" "Game;BoardGame;" "true"
+BUILD_WRKSRC= ${WRKSRC}/quacker
-post-extract:
- @${FIND} ${WRKSRC} \( -name "*.[ao]" -or -name "moc_*" \) -delete
+DESKTOP_ENTRIES="Quackle" "${COMMENT}" "" "quackle" "Game;BoardGame;" "true"
post-patch:
- @${REINPLACE_CMD} -e \
- '/debug/s|^CONFIG|#CONFIG| ; \
- /release/s|^#CONFIG|CONFIG|' ${BUILD_WRKSRC}/quacker.pro
- @${REINPLACE_CMD} -e \
- '/QFile::exists/s|("data")|("${DATADIR}")| ; \
- /setDataDirectory/s|("data")|("${DATADIR}")|' ${BUILD_WRKSRC}/settings.cpp
+ @${REINPLACE_CMD} '/-Wno-unused-local-typedefs/d' \
+ ${BUILD_WRKSRC}/quacker.pro \
+ ${WRKSRC}/quackleio/quackleio.pro
+ @${REINPLACE_CMD} 's|"data"|"${DATADIR}"|' \
+ ${BUILD_WRKSRC}/settings.cpp
post-configure:
.for dir in quackleio quacker
@@ -47,8 +40,8 @@ pre-build:
.endfor
do-install:
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/quacker \
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/Quackle \
${STAGEDIR}${PREFIX}/bin/quackle
- @(cd ${WRKSRC}/data && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
+ (cd ${WRKSRC}/data && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
.include <bsd.port.mk>
diff --git a/games/quackle/distinfo b/games/quackle/distinfo
index 91619b675f3c..b2ffe3288e5b 100644
--- a/games/quackle/distinfo
+++ b/games/quackle/distinfo
@@ -1,2 +1,2 @@
-SHA256 (quackle-0.97-source.tar.gz) = f570dfbafe0d82510ba6cbe4816ae1acabb61733e29a1044e02e6c9060040152
-SIZE (quackle-0.97-source.tar.gz) = 61947124
+SHA256 (quackle-0.98.tar.gz) = 414c693bd2e97b5e8200df853cad04ab49bde3184914dd16f9292451af2ad581
+SIZE (quackle-0.98.tar.gz) = 42197478
diff --git a/games/quackle/pkg-plist b/games/quackle/pkg-plist
index fe2e216baea5..241d3bb4ce32 100644
--- a/games/quackle/pkg-plist
+++ b/games/quackle/pkg-plist
@@ -6,8 +6,9 @@ bin/quackle
%%DATADIR%%/alphabets/greek.quackle_alphabet
%%DATADIR%%/alphabets/korean.quackle_alphabet
%%DATADIR%%/alphabets/mandarin.quackle_alphabet
-%%DATADIR%%/alphabets/mandarin.quackle_alphabet~
+%%DATADIR%%/alphabets/norwegian.quackle_alphabet
%%DATADIR%%/alphabets/pinyin.quackle_alphabet
+%%DATADIR%%/alphabets/polish.quackle_alphabet
%%DATADIR%%/alphabets/russian.quackle_alphabet
%%DATADIR%%/alphabets/swedish.quackle_alphabet
%%DATADIR%%/alphabets/tuvan.quackle_alphabet
@@ -15,51 +16,36 @@ bin/quackle
%%DATADIR%%/lexica/csw12.dawg
%%DATADIR%%/lexica/csw12.gaddag
%%DATADIR%%/lexica/cswapr07.dawg
-%%DATADIR%%/lexica/cswapr07.gaddag
-%%DATADIR%%/lexica/cswjan11.dawg
%%DATADIR%%/lexica/greek.dawg
%%DATADIR%%/lexica/korean.dawg
+%%DATADIR%%/lexica/norwegian.dawg
%%DATADIR%%/lexica/ods5.dawg
+%%DATADIR%%/lexica/osps.dawg
%%DATADIR%%/lexica/russian.dawg
%%DATADIR%%/lexica/sowpods.dawg
%%DATADIR%%/lexica/tuvan.dawg
-%%DATADIR%%/lexica/twl06_wild.dawg
%%DATADIR%%/lexica/twl06.dawg
%%DATADIR%%/lexica/twl06.gaddag
+%%DATADIR%%/lexica/twl06_wild.dawg
%%DATADIR%%/lexica/twl98.dawg
%%DATADIR%%/raw_lexica/cswapr07.raw
%%DATADIR%%/raw_lexica/cswfeb07.raw
-%%DATADIR%%/raw_lexica/faa3.raw
-%%DATADIR%%/raw_lexica/fise-spanish.raw
%%DATADIR%%/raw_lexica/greek.raw
%%DATADIR%%/raw_lexica/korean.raw
+%%DATADIR%%/raw_lexica/norwegian.raw
%%DATADIR%%/raw_lexica/ods4.raw
%%DATADIR%%/raw_lexica/ods5.raw
%%DATADIR%%/raw_lexica/sowpods.raw
%%DATADIR%%/raw_lexica/twl06.raw
%%DATADIR%%/raw_lexica/twl98.raw
-%%DATADIR%%/strategy/chinese/superleaves
-%%DATADIR%%/strategy/chinese/syn2
-%%DATADIR%%/strategy/chinese/worths
-%%DATADIR%%/strategy/cswapr07/superleaves
-%%DATADIR%%/strategy/greek/superleaves
-%%DATADIR%%/strategy/greek/syn2
-%%DATADIR%%/strategy/greek/worths
-%%DATADIR%%/strategy/korean/superleaves
-%%DATADIR%%/strategy/korean/syn2
-%%DATADIR%%/strategy/korean/worths
-%%DATADIR%%/strategy/mandarin/superleaves
-%%DATADIR%%/strategy/mandarin/syn2
-%%DATADIR%%/strategy/mandarin/worths
-%%DATADIR%%/strategy/russian/superleaves
-%%DATADIR%%/strategy/russian/syn2
-%%DATADIR%%/strategy/russian/worths
-%%DATADIR%%/strategy/tuvan/superleaves
-%%DATADIR%%/strategy/tuvan/syn2
-%%DATADIR%%/strategy/tuvan/worths
+%%DATADIR%%/strategy/ods5/superleaves
+%%DATADIR%%/strategy/ods5/worths
%%DATADIR%%/strategy/twl06/bogowin
%%DATADIR%%/strategy/twl06/superleaves
%%DATADIR%%/strategy/twl06/syn2
%%DATADIR%%/strategy/twl06/vcplace
%%DATADIR%%/strategy/twl06/worths
%%DATADIR%%/strategy/twl98/worths
+%%DATADIR%%/themes/modern.ini
+%%DATADIR%%/themes/plain.ini
+%%DATADIR%%/themes/traditional.ini