aboutsummaryrefslogtreecommitdiffstats
path: root/games/quake3-data/Makefile.include
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-10-16 14:36:46 +0800
committeredwin <edwin@FreeBSD.org>2005-10-16 14:36:46 +0800
commit5a5e1c54204cf6364723a7dfed682d720258a22e (patch)
tree6892e57c88d5a63c3c8e46187d7af22d342ad615 /games/quake3-data/Makefile.include
parent244c8c12e6da77d112c96e94dd051af7559d51f6 (diff)
downloadfreebsd-ports-gnome-5a5e1c54204cf6364723a7dfed682d720258a22e.tar.gz
freebsd-ports-gnome-5a5e1c54204cf6364723a7dfed682d720258a22e.tar.zst
freebsd-ports-gnome-5a5e1c54204cf6364723a7dfed682d720258a22e.zip
/~ Hey little files, where are you not joining the others in the repository? ~/
"cvs add *" with a files directory does't always give the right results. Add left over files from previous commit PR: ports/86185 Submitted by: Alejandro Pulver <alejandro@varnet.biz>
Diffstat (limited to 'games/quake3-data/Makefile.include')
-rw-r--r--games/quake3-data/Makefile.include44
1 files changed, 44 insertions, 0 deletions
diff --git a/games/quake3-data/Makefile.include b/games/quake3-data/Makefile.include
new file mode 100644
index 000000000000..cede8bcd61de
--- /dev/null
+++ b/games/quake3-data/Makefile.include
@@ -0,0 +1,44 @@
+# Makefile for defining variables used by other Quake III Arena related ports.
+
+# Package name prefix.
+
+Q3PKGNAMEPREFIX=quake3-
+
+.if ${PORTNAME} != "quake3"
+PKGNAMEPREFIX?= ${Q3PKGNAMEPREFIX}
+.endif
+
+# Dependency to "games/quake3-data".
+
+.if ${PORTNAME} != "data"
+RUN_DEPENDS+= ${Q3DIR}/baseq3/pak1.pk3:${PORTSDIR}/games/quake3-data
+.endif
+
+# Installation directories.
+
+Q3DIR= ${LOCALBASE}/share/quake3
+
+.if ${PORTNAME} == "data" || ${PORTNAME} == "quake3"
+DATADIR?= ${Q3DIR}
+.else
+DATADIR?= ${Q3DIR}/${PORTNAME}
+.endif
+
+DOCSDIR?= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+
+PLIST_SUB+= Q3DIR="${Q3DIR:S/${PREFIX}\///}"
+
+# Convert "dos" text files to "unix".
+
+.if defined(USE_ZIP)
+EXTRACT_BEFORE_ARGS= -aqo
+.else
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i ""
+
+pre-patch:
+# remove trailing ^M
+ @${FIND} -E ${WRKSRC} -type f \
+ -iregex ".*\.(bat|cfg|gam|htm|html|inf|ini|lst|sc|scr|txt|url)" \
+ -exec ${REINPLACE_CMD} -e "s|`${ECHO_CMD} -e '\r'`$$||" {} \;
+.endif