aboutsummaryrefslogtreecommitdiffstats
path: root/games/quake3-data
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-05-12 16:06:32 +0800
committerdanfe <danfe@FreeBSD.org>2013-05-12 16:06:32 +0800
commit50b2719b4dfe3fbff49e79ff267cf440db9fa8f5 (patch)
tree36fe9bc878683842de3c4779e9a7645be41dba81 /games/quake3-data
parent21331e856d86bbccf4a8a14b3761e35227b69126 (diff)
downloadfreebsd-ports-gnome-50b2719b4dfe3fbff49e79ff267cf440db9fa8f5.tar.gz
freebsd-ports-gnome-50b2719b4dfe3fbff49e79ff267cf440db9fa8f5.tar.zst
freebsd-ports-gnome-50b2719b4dfe3fbff49e79ff267cf440db9fa8f5.zip
If port is setting PKGNAMEPREFIX=${FOOPKGNAMEPREFIX}, but .include's this
file before <bsd.port.options.mk>, options handling gets broken because options will be loaded from OPTIONSFILE which is based on UNIQUENAME and thus PKGNAMEPREFIX, which is empty at that point. Prevent this: ensure that FOOPKGNAMEPREFIX is defined in advance for ports that use it to set their PKGNAMEPREFIX and having OPTIONS.
Diffstat (limited to 'games/quake3-data')
-rw-r--r--games/quake3-data/Makefile.include4
1 files changed, 4 insertions, 0 deletions
diff --git a/games/quake3-data/Makefile.include b/games/quake3-data/Makefile.include
index dbd7ff998c07..7c9dd4e9216c 100644
--- a/games/quake3-data/Makefile.include
+++ b/games/quake3-data/Makefile.include
@@ -4,6 +4,10 @@
Q3PKGNAMEPREFIX?= quake3-
Q3DIR?= ${LOCALBASE}/share/quake3
+.if ${PKGNAMEPREFIX} == ${Q3PKGNAMEPREFIX} && defined(OPTIONSMKINCLUDED)
+. error include before <bsd.port.options.mk> if using Q3PKGNAMEPREFIX
+.endif
+
MAKE_ENV+= Q3DIR="${Q3DIR}"
PLIST_SUB+= Q3DIR="${Q3DIR:S/${LOCALBASE}\///}"
SUB_LIST+= Q3DIR="${Q3DIR}"