aboutsummaryrefslogtreecommitdiffstats
path: root/games/quakeforge
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-12-30 05:32:27 +0800
committeralepulver <alepulver@FreeBSD.org>2006-12-30 05:32:27 +0800
commitab048f4a5002128914187ff2d21f45dd5136242f (patch)
tree61bf029a0705d323a6a93ce5de2e4aff40f7b1b4 /games/quakeforge
parent612f4131c48c050c6f5081cf6c538d6b746f9a63 (diff)
downloadfreebsd-ports-gnome-ab048f4a5002128914187ff2d21f45dd5136242f.tar.gz
freebsd-ports-gnome-ab048f4a5002128914187ff2d21f45dd5136242f.tar.zst
freebsd-ports-gnome-ab048f4a5002128914187ff2d21f45dd5136242f.zip
- Correctly disable the use of installed libraries if not selected in OPTIONS.
Diffstat (limited to 'games/quakeforge')
-rw-r--r--games/quakeforge/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/games/quakeforge/Makefile b/games/quakeforge/Makefile
index c6ddf5054867..5fb2bc8b715a 100644
--- a/games/quakeforge/Makefile
+++ b/games/quakeforge/Makefile
@@ -58,7 +58,7 @@ USE_SDL= sdl
CONFIGURE_ARGS+=--with-sdl=${LOCALBASE}
PLIST_SUB+= SDL=""
.else
-CONFIGURE_ARGS+=--without-sdl
+CONFIGURE_ARGS+=--disable-sdl
PLIST_SUB+= SDL="@comment "
.endif
@@ -67,7 +67,7 @@ LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+=--with-ogg=${LOCALBASE} --with-vorbis=${LOCALBASE}
PLIST_SUB+= VORBIS=""
.else
-CONFIGURE_ARGS+=--without-ogg --without-vorbis
+CONFIGURE_ARGS+=--disable-ogg --disable-vorbis
PLIST_SUB+= VORBIS="@comment "
.endif
@@ -76,12 +76,12 @@ LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
CONFIGURE_ARGS+=--with-xmms-prefix=${X11BASE}
PLIST_SUB+= XMMS=""
.else
-CONFIGURE_ARGS+=--without-xmms
+CONFIGURE_ARGS+=--disable-xmms
PLIST_SUB+= XMMS="@comment "
.endif
.else
-CONFIGURE_ARGS+=--without-clients
+CONFIGURE_ARGS+=--with-clients=""
PLIST_SUB+= CLIENTS="@comment "
.endif # WITH_CLIENTS
@@ -96,7 +96,7 @@ CFLAGS+= -ffast-math
.if !defined(WITHOUT_SERVERS)
PLIST_SUB+= SERVERS=""
.else
-CONFIGURE_ARGS+=--without-servers
+CONFIGURE_ARGS+=--with-servers=""
PLIST_SUB+= SERVERS="@comment "
.endif