aboutsummaryrefslogtreecommitdiffstats
path: root/games/qudos
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-05 17:45:36 +0800
committerbapt <bapt@FreeBSD.org>2014-05-05 17:45:36 +0800
commit1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184 (patch)
tree96cc94ba02edcc043c52eb3f26adbc632bbe44d8 /games/qudos
parentd8575795a2106dcbddc552f756cb3916f113f9e0 (diff)
downloadfreebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.tar.gz
freebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.tar.zst
freebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.zip
Convert all :U to :tu and :L to :tl
Since FreeBSD 8.4 and FreeBSD 9.1 make(1) do support :tu and :tl as a replacement for :U and :L (which has been marked as deprecated) bmake which is the default on FreeBSD 10+ only support by default :tu/:tl a hack has been added at the time to support :U and :L to ease migration. This hack is now not necessary anymore Note that this makes the ports tree incompatible with make(1) from FreeBSD 8.3 or earlier With hat: portmgr
Diffstat (limited to 'games/qudos')
-rw-r--r--games/qudos/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/games/qudos/Makefile b/games/qudos/Makefile
index d11ae7eca1f2..fad594fda879 100644
--- a/games/qudos/Makefile
+++ b/games/qudos/Makefile
@@ -114,7 +114,7 @@ MAKE_ENV+= WITH_GAME_MOD=NO
. if ${PORT_OPTIONS:M${opt}}
MAKE_ENV+= BUILD_${opt}=YES
PLIST_SUB+= ${opt}=""
-Q2REF+= ${opt:L}
+Q2REF+= ${opt:tl}
. else
MAKE_ENV+= BUILD_${opt}=NO
PLIST_SUB+= ${opt}="@comment "
@@ -199,8 +199,8 @@ do-install:
.if ${PORT_OPTIONS:MGAME}
${INSTALL_PROGRAM} ${WRKSRC}/quake2/baseq2/game.so ${LIBDIR}/baseq2
.endif
-.for mod in ${MOD_LIST:L}
-.if ${PORT_OPTIONS:M${mod:U}}
+.for mod in ${MOD_LIST:tl}
+.if ${PORT_OPTIONS:M${mod:tu}}
@${MKDIR} ${LIBDIR}/${mod}
${INSTALL_PROGRAM} ${WRKSRC}/quake2/${mod}/game.so ${LIBDIR}/${mod}
.endif