aboutsummaryrefslogtreecommitdiffstats
path: root/games/quetoo
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /games/quetoo
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'games/quetoo')
-rw-r--r--games/quetoo/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/games/quetoo/Makefile b/games/quetoo/Makefile
index ba382dfe9444..7616228192d5 100644
--- a/games/quetoo/Makefile
+++ b/games/quetoo/Makefile
@@ -22,10 +22,10 @@ USE_GL= glut
USE_DOS2UNIX= src/vanctf/g_local.h
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
- OPENGL_CFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= OPENGL_CFLAGS="-I${LOCALBASE}/include" \
OPENGL_LIBS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
LIBDIR= ${PREFIX}/lib/${PORTNAME}
PLIST_SUB+= LIBDIR="${LIBDIR:S/${PREFIX}\///}"