aboutsummaryrefslogtreecommitdiffstats
path: root/games/redeclipse
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2012-09-04 06:33:43 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2012-09-04 06:33:43 +0800
commit0c8904e8b15e817b64a3e6c815f6595ebf64a993 (patch)
tree1fe9f1b2646467a5abb412b9ba57e31990b11c05 /games/redeclipse
parent000f2ac2b0b44a5d282a791c69e62f6ef0c52dfc (diff)
downloadfreebsd-ports-gnome-0c8904e8b15e817b64a3e6c815f6595ebf64a993.tar.gz
freebsd-ports-gnome-0c8904e8b15e817b64a3e6c815f6595ebf64a993.tar.zst
freebsd-ports-gnome-0c8904e8b15e817b64a3e6c815f6595ebf64a993.zip
- Update to 1.3.1
Diffstat (limited to 'games/redeclipse')
-rw-r--r--games/redeclipse/Makefile7
-rw-r--r--games/redeclipse/distinfo4
-rw-r--r--games/redeclipse/files/patch-src_Makefile18
3 files changed, 15 insertions, 14 deletions
diff --git a/games/redeclipse/Makefile b/games/redeclipse/Makefile
index a046dc1b5a7b..e1a2ae311ec2 100644
--- a/games/redeclipse/Makefile
+++ b/games/redeclipse/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= redeclipse
-PORTVERSION= 1.2
-PORTREVISION= 2
+PORTVERSION= 1.3.1
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}_${PORTVERSION}
-DISTNAME= ${PORTNAME}_${PORTVERSION}_linux_bsd
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}_${PORTVERSION:C/^([0-9]+\.[0-9]+)\..*/\1/}
+DISTNAME= ${PORTNAME}_${PORTVERSION}_nix_bsd
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= A single-player and multi-player first-person ego-shooter
diff --git a/games/redeclipse/distinfo b/games/redeclipse/distinfo
index f6cee400e5f7..45e1ee95576e 100644
--- a/games/redeclipse/distinfo
+++ b/games/redeclipse/distinfo
@@ -1,2 +1,2 @@
-SHA256 (redeclipse_1.2_linux_bsd.tar.bz2) = 5fb3e74711011404fa09f4fda26d343e67fda74b515b844bf36b4a39010dc308
-SIZE (redeclipse_1.2_linux_bsd.tar.bz2) = 475330904
+SHA256 (redeclipse_1.3.1_nix_bsd.tar.bz2) = e29bc8a148c00b8a62b0e77752b7494f0d36f428cb4f24e9b5dc40cdcd67254e
+SIZE (redeclipse_1.3.1_nix_bsd.tar.bz2) = 505092683
diff --git a/games/redeclipse/files/patch-src_Makefile b/games/redeclipse/files/patch-src_Makefile
index 31f7c77bf0f1..cf4e5b55f3f6 100644
--- a/games/redeclipse/files/patch-src_Makefile
+++ b/games/redeclipse/files/patch-src_Makefile
@@ -1,18 +1,20 @@
---- src/Makefile.orig 2011-06-08 18:48:21.000000000 +0400
-+++ src/Makefile 2011-07-26 18:26:07.000000000 +0400
-@@ -1,5 +1,4 @@
+--- src/Makefile.orig 2012-08-31 09:59:06.000000000 +0400
++++ src/Makefile 2012-09-03 02:40:29.298539115 +0400
+@@ -3,7 +3,6 @@
+ APPSERVER=reserver
+
#CXXFLAGS= -ggdb3
-CXXFLAGS= -O3 -fomit-frame-pointer
override CXXFLAGS+= -Wall -fsigned-char -fno-exceptions -fno-rtti
PLATFORM= $(shell uname -s)
-@@ -21,8 +20,8 @@
- CLIENT_INCLUDES= -DINTERFACE -DIRC $(INCLUDES) -Iinclude
- CLIENT_LIBS= -mwindows -Llib -lSDL -lSDL_image -lSDL_mixer -lzdll -lopengl32 -lenet -lws2_32 -lwinmm
+@@ -41,8 +40,8 @@
+ CLIENT_INCLUDES= $(INCLUDES) -Iinclude
+ CLIENT_LIBS= -mwindows $(STD_LIBS) -L$(WINBIN) -L$(WINLIB) -lSDL -lSDL_image -lSDL_mixer -lzlib1 -lopengl32 -lenet -lws2_32 -lwinmm
else
--CLIENT_INCLUDES= -DINTERFACE -DIRC $(INCLUDES) -I/usr/X11R6/include `sdl-config --cflags`
+-CLIENT_INCLUDES= $(INCLUDES) -I/usr/X11R6/include `sdl-config --cflags`
-CLIENT_LIBS= -Lenet/.libs -lenet -L/usr/X11R6/lib -lX11 `sdl-config --libs` -lSDL_image -lSDL_mixer -lz -lGL
-+CLIENT_INCLUDES= -DINTERFACE -DIRC $(INCLUDES) -I${LOCALBASE}/include `${SDL_CONFIG} --cflags`
++CLIENT_INCLUDES= $(INCLUDES) -I${LOCALBASE}/include `${SDL_CONFIG} --cflags`
+CLIENT_LIBS= -Lenet/.libs -lenet -L${LOCALBASE}/lib -lX11 `${SDL_CONFIG} --libs` -lSDL_image -lSDL_mixer -lz -lGL
endif
ifeq ($(PLATFORM),Linux)