aboutsummaryrefslogtreecommitdiffstats
path: root/games/reminiscence/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-03-19 06:14:20 +0800
committerpav <pav@FreeBSD.org>2006-03-19 06:14:20 +0800
commit5aae8f253cf9ad0e9664b9a270d60f11d25e0183 (patch)
tree10aa7f6fbdce70dee2927b9015722facee2e1024 /games/reminiscence/Makefile
parent4b24652f61c98bdc5b06f62b6d0aa214fb1e6471 (diff)
downloadfreebsd-ports-gnome-5aae8f253cf9ad0e9664b9a270d60f11d25e0183.tar.gz
freebsd-ports-gnome-5aae8f253cf9ad0e9664b9a270d60f11d25e0183.tar.zst
freebsd-ports-gnome-5aae8f253cf9ad0e9664b9a270d60f11d25e0183.zip
REminiscence is a rewrite of the engine used in the game Flashback
from Delphine Software. This program is designed as a cross-platform replacement for the original executable and uses the SDL library. It allows you to rediscover and play it on modern machines using the original datafiles. WWW: http://membres.lycos.fr/cyxdown/reminiscence/ PR: ports/93168 Submitted by: Dmitry Marakasov <amdmi3@mail.ru>
Diffstat (limited to 'games/reminiscence/Makefile')
-rw-r--r--games/reminiscence/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/games/reminiscence/Makefile b/games/reminiscence/Makefile
new file mode 100644
index 000000000000..10a8e12b5f88
--- /dev/null
+++ b/games/reminiscence/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: REminiscence
+# Date created: 11 Feb 2005
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= REminiscence
+PORTVERSION= 0.1.8
+CATEGORIES= games
+MASTER_SITES= http://membres.lycos.fr/cyxdown/reminiscence/
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= A rewritten engine for Flashback
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_SDL= sdl
+
+ALL_TARGET= rs
+
+PORTDOCS= README
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^CXX =/ d' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '/^CXXFLAGS:=/ d' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '/^CXXFLAGS+=.*-W/ d' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|DATA|${DATADIR}/data|' ${WRKSRC}/main.cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/rs ${PREFIX}/bin/remin
+ ${MKDIR} ${DATADIR}/data
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+ @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
+
+.include <bsd.port.mk>