aboutsummaryrefslogtreecommitdiffstats
path: root/games/rescue
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-10-13 01:26:26 +0800
committerpawel <pawel@FreeBSD.org>2012-10-13 01:26:26 +0800
commit15ed9f23227f7e6b2ddccb4553ad3ecf11215cdb (patch)
tree3cf6b047de6b6fe3a8e5fe7cedad2b470384b91f /games/rescue
parente4a9b471fcd9e2ae27069e3b7ce67e2acb2d1424 (diff)
downloadfreebsd-ports-gnome-15ed9f23227f7e6b2ddccb4553ad3ecf11215cdb.tar.gz
freebsd-ports-gnome-15ed9f23227f7e6b2ddccb4553ad3ecf11215cdb.tar.zst
freebsd-ports-gnome-15ed9f23227f7e6b2ddccb4553ad3ecf11215cdb.zip
Rescue Max is a Action Adventure in Space written in java.
It is based on a old mac game called Rescue! by Tom Spreen. A 2D space real-time, action/strategy game. You are in control of a ship that you fly around space fighting enemies and making friends on your way. The main objective is to rescue people from planets and take them to star bases. WWW: http://rescue.sourceforge.net/ PR: ports/172123 Submitted by: nemysis@gmx.ch Feature safe: yes
Diffstat (limited to 'games/rescue')
-rw-r--r--games/rescue/Makefile51
-rw-r--r--games/rescue/distinfo2
-rw-r--r--games/rescue/files/rescue.in9
-rw-r--r--games/rescue/pkg-descr8
4 files changed, 70 insertions, 0 deletions
diff --git a/games/rescue/Makefile b/games/rescue/Makefile
new file mode 100644
index 000000000000..a1d28b18df72
--- /dev/null
+++ b/games/rescue/Makefile
@@ -0,0 +1,51 @@
+# Created by: nemysis@gmx.ch
+# $FreeBSD$
+
+PORTNAME= rescue
+PORTVERSION= 1.0.0.2
+CATEGORIES= games java
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME:S/r/R/}%21%20Max/${PORTVERSION}/
+DISTNAME= ${PORTNAME:S/r/R/}_${PORTVERSION}
+DIST_SUBDIR= java
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Action Adventure in Space
+
+LICENSE= GPLv2
+
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME:S/r/R/}
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.png
+
+PORTDATA= *
+PORTDOCS= ChangeLog.txt bugs.txt
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+
+SUB_FILES= ${PORTNAME}
+
+DESKTOP_ENTRIES="Rescue! Max" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Game;StrategyGame;" "false"
+
+.include <bsd.port.options.mk>
+
+post-extract:
+ @(cd ${WRKSRC} && ${UNZIP_CMD} -j Rescue.jar rescue/gui/logo.png)
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} "help missions *.jar" ${DATADIR})
+ ${INSTALL_DATA} ${WRKSRC}/logo.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
+
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/rescue/distinfo b/games/rescue/distinfo
new file mode 100644
index 000000000000..2cacee1d26cf
--- /dev/null
+++ b/games/rescue/distinfo
@@ -0,0 +1,2 @@
+SHA256 (java/Rescue_1.0.0.2.zip) = 38cb6f68f2dafcc44a4b34b65a2ab36136d37029c60136646068da4634e8f5b3
+SIZE (java/Rescue_1.0.0.2.zip) = 3907836
diff --git a/games/rescue/files/rescue.in b/games/rescue/files/rescue.in
new file mode 100644
index 000000000000..95f461472762
--- /dev/null
+++ b/games/rescue/files/rescue.in
@@ -0,0 +1,9 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+export JAVA_VERSION="%%JAVA_VERSION%%"
+
+cd "%%DATADIR%%" && exec "%%LOCALBASE%%/bin/java" \
+-Djava.ext.dirs="%%DATADIR%%" -jar "%%DATADIR%%/Rescue.jar" "${@}"
diff --git a/games/rescue/pkg-descr b/games/rescue/pkg-descr
new file mode 100644
index 000000000000..4761c39d963c
--- /dev/null
+++ b/games/rescue/pkg-descr
@@ -0,0 +1,8 @@
+Rescue Max is a Action Adventure in Space written in java.
+It is based on a old mac game called Rescue! by Tom Spreen.
+
+A 2D space real-time, action/strategy game. You are in control of a ship that
+you fly around space fighting enemies and making friends on your way.
+The main objective is to rescue people from planets and take them to star bases.
+
+WWW: http://rescue.sourceforge.net/