aboutsummaryrefslogtreecommitdiffstats
path: root/games/robocode
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-03-23 23:16:06 +0800
committernemysis <nemysis@FreeBSD.org>2014-03-23 23:16:06 +0800
commit0b318959978aa14ce33d9cf1adf71ae2cd55f27c (patch)
tree707a5169654bb888bc13ed96d5e82491f6d49d9f /games/robocode
parentfb8f13ad3b2121000acc740be7bc8cb3874a7927 (diff)
downloadfreebsd-ports-gnome-0b318959978aa14ce33d9cf1adf71ae2cd55f27c.tar.gz
freebsd-ports-gnome-0b318959978aa14ce33d9cf1adf71ae2cd55f27c.tar.zst
freebsd-ports-gnome-0b318959978aa14ce33d9cf1adf71ae2cd55f27c.zip
- Update to 1.9.1.0, announce message is here:
http://sourceforge.net/projects/robocode/files/robocode/1.9.1.0/ - Change master sites, use supplied icons, i have wrote what is to change more in support-requests 22 - USES dos2unix instead of USE_DOS2UNIX, upstream have many fixed - Remove DOSC and Option, DOCS are used from within the game, so this is unconditional - Add files robocode-MeleeRumble, robocode-RoboRumble, robocode-Robocode, robocode-TeamRumble, robocode-TwinDuel, according to Upstream .sh files - Remove Desktop entry file, use supplied desktop files - Add pkg-deinstall - Change pkg-message, remove deinstallation information, add Warning
Diffstat (limited to 'games/robocode')
-rw-r--r--games/robocode/Makefile41
-rw-r--r--games/robocode/distinfo6
-rw-r--r--games/robocode/files/pkg-deinstall.in18
-rw-r--r--games/robocode/files/pkg-message.in5
-rw-r--r--games/robocode/files/robocode-MeleeRumble.in10
-rw-r--r--games/robocode/files/robocode-RoboRumble.in10
-rw-r--r--games/robocode/files/robocode-Robocode.in9
-rw-r--r--games/robocode/files/robocode-TeamRumble.in10
-rw-r--r--games/robocode/files/robocode-TwinDuel.in10
-rw-r--r--games/robocode/files/robocode-sh.in9
-rw-r--r--games/robocode/pkg-plist25
11 files changed, 113 insertions, 40 deletions
diff --git a/games/robocode/Makefile b/games/robocode/Makefile
index 29bf336f3b93..148025b837af 100644
--- a/games/robocode/Makefile
+++ b/games/robocode/Makefile
@@ -2,58 +2,53 @@
# $FreeBSD$
PORTNAME= robocode
-PORTVERSION= 1.8.3.0
+PORTVERSION= 1.9.1.0
CATEGORIES= games java
-MASTER_SITES= SF \
- SF/nemysisfreebsdp/:icons
-DISTFILES= ${PORTNAME}-${DISTVERSION}-setup.jar \
- ${PORTNAME}.png:icons
+MASTER_SITES= SF
+DISTFILES= ${PORTNAME}-${DISTVERSION}-setup.jar
DIST_SUBDIR= java
-EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}-setup.jar
MAINTAINER= nemysis@FreeBSD.org
COMMENT= Game for learning Java[tm] programming language
LICENSE= EPL
-USES= zip
+USES= dos2unix zip
+DOS2UNIX_GLOB= *.html *.css *.team package-list
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_EXTRACT= yes
JAVA_RUN= yes
NO_WRKSUBDIR= yes
NO_BUILD= yes
-USE_DOS2UNIX= *.html *.MF *.battle *.java *.txt *.properties *.tpt
-PORTDOCS= ReadMe.html ReadMe.txt versions.md
DATADIR= ${JAVASHAREDIR}/${PORTNAME}
PLIST_SUB= PORTVERSION=${PORTVERSION}
-SUB_FILES= ${PORTNAME}-sh pkg-message
-
-DESKTOP_ENTRIES="Robocode" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME}" "Game;StrategyGame;" false
-
-OPTIONS_DEFINE= DOCS
+SUB_FILES= ${PORTNAME}-MeleeRumble ${PORTNAME}-RoboRumble \
+ ${PORTNAME}-Robocode ${PORTNAME}-TeamRumble \
+ ${PORTNAME}-TwinDuel pkg-deinstall pkg-message
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}-sh ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}-* \
+ ${STAGEDIR}${PREFIX}/bin/
-.for d in battles compilers javadoc libs license roborumble robots templates
+.for d in battles compilers javadoc libs license roborumble robots \
+ templates theme
@(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${STAGEDIR}${DATADIR})
.endfor
-.for d in *.ico *.sh versions.md
- @(${INSTALL_DATA} ${WRKSRC}/${d} ${STAGEDIR}${DATADIR})
+.for f in *.ico *.sh ReadMe.* versions.md
+ @(${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DATADIR})
.endfor
- ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png ${STAGEDIR}${PREFIX}/share/pixmaps/
+ ${INSTALL_DATA} ${WRKSRC}/desktop/*.desktop ${STAGEDIR}${DESKTOPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/desktop/*.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
@${MKDIR} ${STAGEDIR}${DATADIR}/config
@(cd ${STAGEDIR}${DATADIR} && ${CHMOD} -R 775 config roborumble robots)
@${CHMOD} +x ${STAGEDIR}${DATADIR}/*.sh
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-
.include <bsd.port.mk>
diff --git a/games/robocode/distinfo b/games/robocode/distinfo
index ad05ed2cf22c..2f8438befb1d 100644
--- a/games/robocode/distinfo
+++ b/games/robocode/distinfo
@@ -1,4 +1,2 @@
-SHA256 (java/robocode-1.8.3.0-setup.jar) = b6e6bdafec55f924e2b49edb37e85906773b7cf9fc900b837eac2cfcd4b7cd51
-SIZE (java/robocode-1.8.3.0-setup.jar) = 5317001
-SHA256 (java/robocode.png) = f828749aacde1f1ee58a0f838e1e0e60bf2950153e3891687ff8a1734d3fcfa7
-SIZE (java/robocode.png) = 1823
+SHA256 (java/robocode-1.9.1.0-setup.jar) = 0d342be7176cbd6d3f5fd79b4ce864194114018012a0b4b9a81099fb1bba6b61
+SIZE (java/robocode-1.9.1.0-setup.jar) = 5432274
diff --git a/games/robocode/files/pkg-deinstall.in b/games/robocode/files/pkg-deinstall.in
new file mode 100644
index 000000000000..4b297e3acd1f
--- /dev/null
+++ b/games/robocode/files/pkg-deinstall.in
@@ -0,0 +1,18 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+if [ "$2" = "POST-DEINSTALL" ]; then
+ echo ""
+ echo ""
+ echo "==============================================================================="
+ echo ""
+ echo "After deinstallation, some files may stay in %%DATADIR%%,"
+ echo "you can delete them with"
+ echo ""
+ echo " /bin/rm -fr %%DATADIR%%"
+ echo ""
+ echo "==============================================================================="
+ echo ""
+fi
diff --git a/games/robocode/files/pkg-message.in b/games/robocode/files/pkg-message.in
index 5a93609fdc05..a335633ebb9f 100644
--- a/games/robocode/files/pkg-message.in
+++ b/games/robocode/files/pkg-message.in
@@ -10,9 +10,8 @@ You can override this in the Robocode compiler preferences menu:
Robot -> Editor -> Compiler -> Options -> Preferences
-After deinstallation, some files may stay in %%DATADIR%%,
-you can delete them with
+Attention not all with Rumble games works, this is work in Progress.
- /bin/rm -fr %%DATADIR%%
+Have fun!
==============================================================================
diff --git a/games/robocode/files/robocode-MeleeRumble.in b/games/robocode/files/robocode-MeleeRumble.in
new file mode 100644
index 000000000000..aaf841419c3e
--- /dev/null
+++ b/games/robocode/files/robocode-MeleeRumble.in
@@ -0,0 +1,10 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+export JAVA_VERSION="%%JAVA_VERSION%%"
+
+cd "%%DATADIR%%" && exec "%%LOCALBASE%%/bin/java" -Xmx1024M \
+-cp "libs/robocode.jar:libs/roborumble.jar:libs/codesize-1.1.jar" \
+roborumble.RoboRumbleAtHome ./roborumble/meleerumble.txt "${@}"
diff --git a/games/robocode/files/robocode-RoboRumble.in b/games/robocode/files/robocode-RoboRumble.in
new file mode 100644
index 000000000000..f435b4f37728
--- /dev/null
+++ b/games/robocode/files/robocode-RoboRumble.in
@@ -0,0 +1,10 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+export JAVA_VERSION="%%JAVA_VERSION%%"
+
+cd "%%DATADIR%%" && exec "%%LOCALBASE%%/bin/java" -Xmx512M \
+-cp "libs/robocode.jar:libs/roborumble.jar:libs/codesize-1.1.jar" \
+roborumble.RoboRumbleAtHome ./roborumble/roborumble.txt "${@}"
diff --git a/games/robocode/files/robocode-Robocode.in b/games/robocode/files/robocode-Robocode.in
new file mode 100644
index 000000000000..ba2645a19fd4
--- /dev/null
+++ b/games/robocode/files/robocode-Robocode.in
@@ -0,0 +1,9 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+export JAVA_VERSION="%%JAVA_VERSION%%"
+
+cd "%%DATADIR%%" && exec "%%LOCALBASE%%/bin/java" -Xmx512M \
+-cp "libs/robocode.jar" robocode.Robocode "${@}"
diff --git a/games/robocode/files/robocode-TeamRumble.in b/games/robocode/files/robocode-TeamRumble.in
new file mode 100644
index 000000000000..f435b4f37728
--- /dev/null
+++ b/games/robocode/files/robocode-TeamRumble.in
@@ -0,0 +1,10 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+export JAVA_VERSION="%%JAVA_VERSION%%"
+
+cd "%%DATADIR%%" && exec "%%LOCALBASE%%/bin/java" -Xmx512M \
+-cp "libs/robocode.jar:libs/roborumble.jar:libs/codesize-1.1.jar" \
+roborumble.RoboRumbleAtHome ./roborumble/roborumble.txt "${@}"
diff --git a/games/robocode/files/robocode-TwinDuel.in b/games/robocode/files/robocode-TwinDuel.in
new file mode 100644
index 000000000000..910a136ca357
--- /dev/null
+++ b/games/robocode/files/robocode-TwinDuel.in
@@ -0,0 +1,10 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+export JAVA_VERSION="%%JAVA_VERSION%%"
+
+cd "%%DATADIR%%" && exec "%%LOCALBASE%%/bin/java" -Xmx512M \
+-cp "libs/robocode.jar:libs/roborumble.jar:libs/codesize-1.1.jar" \
+roborumble.RoboRumbleAtHome ./roborumble/twinduel.txt "${@}"
diff --git a/games/robocode/files/robocode-sh.in b/games/robocode/files/robocode-sh.in
deleted file mode 100644
index 36b18d485b6d..000000000000
--- a/games/robocode/files/robocode-sh.in
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-export JAVA_VERSION="%%JAVA_VERSION%%"
-
-cd "%%DATADIR%%" && exec "%%LOCALBASE%%/bin/java" -Djava.ext.dirs="%%DATADIR%%" \
--Djava.ext.dirs="%%DATADIR%%" -cp libs/robocode.jar robocode.Robocode "${@}"
diff --git a/games/robocode/pkg-plist b/games/robocode/pkg-plist
index 5735a02dcb10..c64baf3c8188 100644
--- a/games/robocode/pkg-plist
+++ b/games/robocode/pkg-plist
@@ -1,4 +1,15 @@
-bin/robocode
+bin/robocode-MeleeRumble
+bin/robocode-RoboRumble
+bin/robocode-Robocode
+bin/robocode-TeamRumble
+bin/robocode-TwinDuel
+share/applications/robocodeMeleeRumble.desktop
+share/applications/robocodeRoboRumble.desktop
+share/applications/robocodeRobocode.desktop
+share/applications/robocodeTeamRumble.desktop
+share/applications/robocodeTwinDuel.desktop
+%%DATADIR%%/ReadMe.html
+%%DATADIR%%/ReadMe.txt
%%DATADIR%%/battles/intro.battle
%%DATADIR%%/battles/sample.battle
%%DATADIR%%/compilers/CompilerTest.java
@@ -19,6 +30,7 @@ bin/robocode
%%DATADIR%%/javadoc/robocode/BattleEndedEvent.html
%%DATADIR%%/javadoc/robocode/BattleResults.html
%%DATADIR%%/javadoc/robocode/BattleRules.html
+%%DATADIR%%/javadoc/robocode/BorderSentry.html
%%DATADIR%%/javadoc/robocode/Bullet.html
%%DATADIR%%/javadoc/robocode/BulletHitBulletEvent.html
%%DATADIR%%/javadoc/robocode/BulletHitEvent.html
@@ -181,6 +193,7 @@ bin/robocode
%%DATADIR%%/robots/sample/Interactive_v2$Direction.class
%%DATADIR%%/robots/sample/Interactive_v2.class
%%DATADIR%%/robots/sample/Interactive_v2.java
+%%DATADIR%%/robots/sample/Interactive_v2.properties
%%DATADIR%%/robots/sample/MyFirstJuniorRobot.class
%%DATADIR%%/robots/sample/MyFirstJuniorRobot.java
%%DATADIR%%/robots/sample/MyFirstJuniorRobot.properties
@@ -234,6 +247,10 @@ bin/robocode
%%DATADIR%%/robots/sampleex/RegullarMonk.java
%%DATADIR%%/robots/sampleex/Slave.class
%%DATADIR%%/robots/sampleex/Slave.java
+%%DATADIR%%/robots/samplesentry/BorderGuard$RobotData.class
+%%DATADIR%%/robots/samplesentry/BorderGuard.class
+%%DATADIR%%/robots/samplesentry/BorderGuard.java
+%%DATADIR%%/robots/samplesentry/BorderGuard.properties
%%DATADIR%%/robots/sampleteam/MyFirstDroid.class
%%DATADIR%%/robots/sampleteam/MyFirstDroid.java
%%DATADIR%%/robots/sampleteam/MyFirstLeader.class
@@ -247,11 +264,17 @@ bin/robocode
%%DATADIR%%/templates/newjavafile.tpt
%%DATADIR%%/templates/newjuniorrobot.tpt
%%DATADIR%%/templates/newrobot.tpt
+%%DATADIR%%/theme/editor/Robocode Black Theme.properties
+%%DATADIR%%/theme/editor/Robocode White Theme.properties
%%DATADIR%%/twinduel.sh
%%DATADIR%%/versions.md
share/pixmaps/robocode.png
+share/pixmaps/roborumble.png
+@dirrm %%DATADIR%%/theme/editor
+@dirrm %%DATADIR%%/theme
@dirrm %%DATADIR%%/templates
@dirrm %%DATADIR%%/robots/sampleteam
+@dirrm %%DATADIR%%/robots/samplesentry
@dirrm %%DATADIR%%/robots/sampleex
@dirrmtry %%DATADIR%%/robots/sample
@dirrmtry %%DATADIR%%/robots