aboutsummaryrefslogtreecommitdiffstats
path: root/games/rocksndiamonds/Makefile
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2001-02-15 06:22:15 +0800
committersf <sf@FreeBSD.org>2001-02-15 06:22:15 +0800
commit8b98e1ec0b6d49ad84e259f1321ef6ce9145cd7c (patch)
tree612147836054a0811c2caa131122e986445896d4 /games/rocksndiamonds/Makefile
parentba1c00ad5ddeabda83ea37ef3b1acede0ae98983 (diff)
downloadfreebsd-ports-gnome-8b98e1ec0b6d49ad84e259f1321ef6ce9145cd7c.tar.gz
freebsd-ports-gnome-8b98e1ec0b6d49ad84e259f1321ef6ce9145cd7c.tar.zst
freebsd-ports-gnome-8b98e1ec0b6d49ad84e259f1321ef6ce9145cd7c.zip
o update to 2.0.0.
o add SDL support. PR: 24731 Submitted by: maintainer
Diffstat (limited to 'games/rocksndiamonds/Makefile')
-rw-r--r--games/rocksndiamonds/Makefile22
1 files changed, 14 insertions, 8 deletions
diff --git a/games/rocksndiamonds/Makefile b/games/rocksndiamonds/Makefile
index 1501c1d8839c..fe90e35b0d6f 100644
--- a/games/rocksndiamonds/Makefile
+++ b/games/rocksndiamonds/Makefile
@@ -6,18 +6,19 @@
#
PORTNAME= rocksndiamonds
-PORTVERSION= 1.4.0
-PORTREVISION= 1
+PORTVERSION= 2.0.0
CATEGORIES= games
-MASTER_SITES= http://www.artsoft.org/rocksndiamonds/RELEASES/ \
- ${MASTER_SITE_XCONTRIB}
-MASTER_SITE_SUBDIR= games
-
-PATCH_SITES= http://www.artsoft.org/RELEASES/
-PATCHFILES= rocksndiamonds-1.4.0pl1.diff
+MASTER_SITES= http://www.artsoft.org/RELEASES/unix/rocksndiamonds/ \
+ http://homepages.compuserve.de/rocksndiamonds/
MAINTAINER= mwest@uct.ac.za
+.if defined(WITH_SDL)
+LIB_DEPENDS= SDL_image.10:${PORTSDIR}/graphics/sdl_image \
+ SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
+MAKE_ARGS+= sdl
+.endif
+
USE_XLIB= yes
USE_GMAKE= yes
MAKE_ENV+= RO_GAME_DIR=${GAME_DIR} RW_GAME_DIR=${GAME_DIR}/scores \
@@ -29,6 +30,11 @@ MAKE_ENV+= JOYSTICK="-DNO_JOYSTICK"
GAME_DIR=${PREFIX}/share/rocksndiamonds
DOC_DIR=${PREFIX}/share/doc/rocksndiamonds
+.if defined(WITH_SDL)
+pre-patch:
+ @${PERL} -pi.orig -e 's:sdl-config:sdl11-config:g' ${WRKSRC}/src/Makefile
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/rocksndiamonds ${PREFIX}/bin
@${MKDIR} ${GAME_DIR}