aboutsummaryrefslogtreecommitdiffstats
path: root/games/rtcw-paks
diff options
context:
space:
mode:
authornik <nik@FreeBSD.org>2002-03-03 06:44:05 +0800
committernik <nik@FreeBSD.org>2002-03-03 06:44:05 +0800
commit1b2237de30628941e8556cc4e4443c514325c4b4 (patch)
treeb1f564661c8fe8f16417ea01201a9a26f8310c92 /games/rtcw-paks
parent38d7c6b37159030f1af8e4a349e300b8276c8c9e (diff)
downloadfreebsd-ports-gnome-1b2237de30628941e8556cc4e4443c514325c4b4.tar.gz
freebsd-ports-gnome-1b2237de30628941e8556cc4e4443c514325c4b4.tar.zst
freebsd-ports-gnome-1b2237de30628941e8556cc4e4443c514325c4b4.zip
Wrap the .pk3 files required by Return to Castle Wolfenstein. You still need
the retail CD, this just makes things a little more integated. Sponsored by: Multiplay UK (www.multiplay.co.uk)
Diffstat (limited to 'games/rtcw-paks')
-rw-r--r--games/rtcw-paks/Makefile49
-rw-r--r--games/rtcw-paks/pkg-comment1
-rw-r--r--games/rtcw-paks/pkg-descr4
-rw-r--r--games/rtcw-paks/pkg-plist6
4 files changed, 60 insertions, 0 deletions
diff --git a/games/rtcw-paks/Makefile b/games/rtcw-paks/Makefile
new file mode 100644
index 000000000000..5d34b587df83
--- /dev/null
+++ b/games/rtcw-paks/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: Return to Castle Wolfenstein paks
+# Date created: Sat Jul 15 14:27:16 SAST 2000
+# Whom: nik@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= rtcw-paks
+PORTVERSION= 1.0
+CATEGORIES= games linux
+MASTER_SITES= #
+DISTFILES= mp_pak0.pk3 mp_pak1.pk3 mp_pak2.pk3 \
+ pak0.pk3 \
+ sp_pak1.pk3 sp_pak2.pk3
+DIST_SUBDIR= rtcw-paks
+IGNOREFILES= ${ALLFILES}
+
+MAINTAINER= nik@FreeBSD.org
+
+# Make this a BUILD_ rather than a RUN_DEPEND so that it can create the
+# directory hierarchy for us.
+BUILD_DEPENDS= ${PREFIX}/usr/games/rtcw/wolf.x86:${PORTSDIR}/games/rtcw
+
+ONLY_FOR_ARCHS= i386
+USE_LINUX_PREFIX= yes
+EXTRACT_ONLY= # Don't extract anything
+STRIP=
+
+GAMEDIR= ${PREFIX}/usr/games/rtcw/
+
+.include <bsd.port.pre.mk>
+
+.for file in ${DISTFILES}
+.if !exists(${DISTDIR}/rtcw-paks/${file})
+IGNORE=You must manually copy all the .pk3 files from the main/ directory of an installed version of the game to the ${DISTDIR}/rtcw-paks directory and then run make again.
+.endif
+.endfor
+
+# Do nothing for the build. Don't set NO_BUILD because of the earlier
+# BUILD_DEPENDS
+do-build:
+
+do-install:
+ ${MKDIR} -p ${GAMEDIR}/main
+.for file in ${DISTFILES}
+ ${INSTALL_DATA} ${DISTDIR}/rtcw-paks/${file} ${GAMEDIR}/main
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/games/rtcw-paks/pkg-comment b/games/rtcw-paks/pkg-comment
new file mode 100644
index 000000000000..723f7449d268
--- /dev/null
+++ b/games/rtcw-paks/pkg-comment
@@ -0,0 +1 @@
+Return to Castle Wolfenstein for Linux .pk3 files
diff --git a/games/rtcw-paks/pkg-descr b/games/rtcw-paks/pkg-descr
new file mode 100644
index 000000000000..0e042a374f2d
--- /dev/null
+++ b/games/rtcw-paks/pkg-descr
@@ -0,0 +1,4 @@
+Return to Castle Wolfenstein for Linux, .pk3 files
+
+This port encapsulates the .pk3 files for RTCW that are used to complete
+the installation of the game (including the dedicated server).
diff --git a/games/rtcw-paks/pkg-plist b/games/rtcw-paks/pkg-plist
new file mode 100644
index 000000000000..a9c76a4bde87
--- /dev/null
+++ b/games/rtcw-paks/pkg-plist
@@ -0,0 +1,6 @@
+usr/games/rtcw/main/mp_pak0.pk3
+usr/games/rtcw/main/mp_pak1.pk3
+usr/games/rtcw/main/mp_pak2.pk3
+usr/games/rtcw/main/pak0.pk3
+usr/games/rtcw/main/sp_pak1.pk3
+usr/games/rtcw/main/sp_pak2.pk3