aboutsummaryrefslogtreecommitdiffstats
path: root/games/rubix/Makefile
diff options
context:
space:
mode:
authorcpiazza <cpiazza@FreeBSD.org>2000-01-04 04:17:40 +0800
committercpiazza <cpiazza@FreeBSD.org>2000-01-04 04:17:40 +0800
commit63e860182dc9ee7849617c9dbdfaa47f6309a745 (patch)
tree77833c46c5aa866729269c3edf772a1830945ff5 /games/rubix/Makefile
parent28b061f08a0eefadfbbc3e99b2e744a40fc0e7b1 (diff)
downloadfreebsd-ports-gnome-63e860182dc9ee7849617c9dbdfaa47f6309a745.tar.gz
freebsd-ports-gnome-63e860182dc9ee7849617c9dbdfaa47f6309a745.tar.zst
freebsd-ports-gnome-63e860182dc9ee7849617c9dbdfaa47f6309a745.zip
Add rubix port.
Rubix is another X11-based incarnation of the world-famous "Rubik's Cube" game. It has the capability of saving games, which, according to the author, can't be found in any other Rubik's Cube games. PR: 15807 Submitted by: Will Andrews <andrews@technologist.com>
Diffstat (limited to 'games/rubix/Makefile')
-rw-r--r--games/rubix/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/games/rubix/Makefile b/games/rubix/Makefile
new file mode 100644
index 000000000000..e318441f951c
--- /dev/null
+++ b/games/rubix/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: rubix
+# Version required: 1.0.1
+# Date created: 19 Nov 1999
+# Whom: Will Andrews <andrews@technologist.com>
+#
+# $FreeBSD$
+#
+
+DISTNAME= rubix-1.0.1
+CATEGORIES= games
+MASTER_SITES= http://sed.free.fr/rubix/
+
+MAINTAINER= andrews@technologist.com
+
+USE_GMAKE= yes
+MAKE_ENV= GMAKE=${GMAKE}
+USE_X_PREFIX= yes
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/rubix ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/rubix
+ @${INSTALL_DATA} ${WRKSRC}/module.xm ${PREFIX}/share/rubix
+.if !defined(NOPORTDOCS)
+.for DOC in AUTHORS BUGS INSTALL NOISE README TODO
+ @${INSTALL_DATA} ${WRKSRC}/${DOC} ${PREFIX}/share/rubix
+.endfor
+ @${ECHO}
+ @${ECHO} "Docs are installed in ${PREFIX}/share/rubix."
+ @${ECHO}
+.endif
+
+.include <bsd.port.mk>