aboutsummaryrefslogtreecommitdiffstats
path: root/games/scare
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-11-10 23:41:29 +0800
committerdanilo <danilo@FreeBSD.org>2013-11-10 23:41:29 +0800
commit4b8e55bb68e8fbe4f837100a34cc98b10a92e90a (patch)
tree9fdc913acb83a2665a05fe1e212ee7ceb6cbf7e6 /games/scare
parent7291f4b4c1ee997ff462428f0d4364a2da3bdb2e (diff)
downloadfreebsd-ports-gnome-4b8e55bb68e8fbe4f837100a34cc98b10a92e90a.tar.gz
freebsd-ports-gnome-4b8e55bb68e8fbe4f837100a34cc98b10a92e90a.tar.zst
freebsd-ports-gnome-4b8e55bb68e8fbe4f837100a34cc98b10a92e90a.zip
- Use options helpers
- Add stage support
Diffstat (limited to 'games/scare')
-rw-r--r--games/scare/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/games/scare/Makefile b/games/scare/Makefile
index f51a883cc7f2..7f6e2597a221 100644
--- a/games/scare/Makefile
+++ b/games/scare/Makefile
@@ -25,15 +25,12 @@ USE_ZIP= yes
PLIST_FILES= bin/scare
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+XGLK_BUILD_DEPENDS= ${LOCALBASE}/lib/libxglk.a:${PORTSDIR}/games/xglk
+XGLK_RUN_DEPENDS= ${LOCALBASE}/lib/libxglk.a:${PORTSDIR}/games/xglk
+XGLK_ALL_TARGET= scare glkscare
+XGLK_PLIST_FILES= bin/glkscare
-.if ${PORT_OPTIONS:MXGLK}
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libxglk.a:${PORTSDIR}/games/xglk
-RUN_DEPENDS+= ${LOCALBASE}/lib/libxglk.a:${PORTSDIR}/games/xglk
-ALL_TARGET= scare glkscare
-PLIST_FILES+= bin/glkscare
-.endif
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e \
@@ -55,9 +52,9 @@ do-configure:
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/source/scare ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/source/scare ${STAGEDIR}${PREFIX}/bin
.if ${PORT_OPTIONS:MXGLK}
- ${INSTALL_PROGRAM} ${WRKSRC}/source/glkscare ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/source/glkscare ${STAGEDIR}${PREFIX}/bin
.endif
test: build