aboutsummaryrefslogtreecommitdiffstats
path: root/games/scummvm-tools/Makefile
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2003-06-02 09:42:36 +0800
committeradamw <adamw@FreeBSD.org>2003-06-02 09:42:36 +0800
commit8371c036440af348a4589d57a29ee20573469bae (patch)
tree964a3043cd89f615f037e1495db63e2bbfccee65 /games/scummvm-tools/Makefile
parentc0faa62c9115068d160ffe961af39687455e10cd (diff)
downloadfreebsd-ports-gnome-8371c036440af348a4589d57a29ee20573469bae.tar.gz
freebsd-ports-gnome-8371c036440af348a4589d57a29ee20573469bae.tar.zst
freebsd-ports-gnome-8371c036440af348a4589d57a29ee20573469bae.zip
Add scummvm-tools.
This is a collection of various tools that may be useful to use in conjunction with ScummVM. It includes tools that will allow you to decompile and extract SCUMM scripts from various games, as well as graphics and sound. Of special note is the extract utility, which uses libmp3lame to compress a monster.sou file to about 25% its original size.
Diffstat (limited to 'games/scummvm-tools/Makefile')
-rw-r--r--games/scummvm-tools/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/games/scummvm-tools/Makefile b/games/scummvm-tools/Makefile
new file mode 100644
index 000000000000..e07ef459e5bc
--- /dev/null
+++ b/games/scummvm-tools/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: scummvm-tools
+# Date created: 28 May 2003
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scummvm-tools
+PORTVERSION= 0.4.1
+CATEGORIES= games emulators
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= scummvm
+
+MAINTAINER= flynn@energyhq.es.eu.org
+COMMENT= Tools for use with the SCUMMVM game emulator
+
+RUN_DEPENDS= scummvm:${PORTSDIR}/games/scummvm
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's@:= -g -O@+= ${CFLAGS}@' \
+ ${WRKSRC}/Makefile
+
+do-install:
+.for i in extract rescumm descumm descumm6 simon1decr simon2mp3
+ @${INSTALL_PROGRAM} ${WRKSRC}/$i ${PREFIX}/bin
+.endfor
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>