aboutsummaryrefslogtreecommitdiffstats
path: root/games/sdb/Makefile
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-09-11 00:24:05 +0800
committerjylefort <jylefort@FreeBSD.org>2005-09-11 00:24:05 +0800
commit6fe80d4876f5dbb681266547c24d52c8637803b1 (patch)
tree576425d750ffd3cd3b46883d9c2f4339904c913d /games/sdb/Makefile
parentdac3a32c30df127dfce02a6becfb6f614452dae9 (diff)
downloadfreebsd-ports-gnome-6fe80d4876f5dbb681266547c24d52c8637803b1.tar.gz
freebsd-ports-gnome-6fe80d4876f5dbb681266547c24d52c8637803b1.tar.zst
freebsd-ports-gnome-6fe80d4876f5dbb681266547c24d52c8637803b1.zip
Add sdb.
Shotgun Debugger is a 2D, top-down action game. It is The Future, and your habit of computer network exploration has finally done you in. You are captured and taken to a strange underground complex populated by robot soldiers. Your task is to escape the facility--but the hordes of walking death machines aren't just gonna let you. Shotgun Debugger is pseudo-3D -- while gameplay is strictly two-dimensional, the world is rendered in three dimensions. Worlds are not tile-based, but polygon-based -- rooms and hallways can be made to any shape imaginable, allowing for some rather impressive architecture. WWW: http://sdb.gamecreation.org/ PR: ports/85857 Submitted by: Dmitry Marakasov <amdmi3@mail.ru>
Diffstat (limited to 'games/sdb/Makefile')
-rw-r--r--games/sdb/Makefile61
1 files changed, 61 insertions, 0 deletions
diff --git a/games/sdb/Makefile b/games/sdb/Makefile
new file mode 100644
index 000000000000..9d1e9f51762a
--- /dev/null
+++ b/games/sdb/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: sdb
+# Date created: 08 Sep 2005
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sdb
+PORTVERSION= 1.0.2
+CATEGORIES= games
+MASTER_SITES= http://gcsociety.sp.cs.cmu.edu/~frenzy/
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Futuristic overhead shooter
+
+USE_X_PREFIX= yes
+USE_SDL= mixer image sdl
+USE_GL= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_GCC= 3.4+
+
+BUILD_WRKSRC= ${WRKSRC}/src
+
+CPPFLAGS= `${SDL_CONFIG} --cflags` -I${X11BASE}/include
+LDFLAGS= `${SDL_CONFIG} --libs` -L${X11BASE}/lib -lSDL_image -lSDL_mixer -lGL -lGLU
+MAKE_ARGS= CPP="${CXX}" CXXFLAGS="${CXXFLAGS} ${CPPFLAGS}" LIBS="${LDFLAGS}"
+
+PLIST_FILES= bin/sdb
+PLIST_DIRS= %%DATADIR%%
+PORTDOCS= README
+
+PLIST= ${WRKDIR}/pkg-plist
+DATADIRS= levels models snd sprites
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|<SDL/|<|' ${WRKSRC}/src/sdb.h
+ @${REINPLACE_CMD} -Ee 's,(levels|models|snd|sprites)/,${DATADIR}/&,g' \
+ ${WRKSRC}/src/sdb.h ${WRKSRC}/src/game.cpp
+
+pre-install:
+ @${RM} -f ${PLIST}
+ @cd ${WRKSRC} && \
+ ${FIND} ${DATADIRS} ! -type d | ${SORT} \
+ | ${SED} -e 's|^|%%DATADIR%%/|' >> ${PLIST} && \
+ ${FIND} ${DATADIRS} -type d ! -empty | ${SORT} -r \
+ | ${SED} -e 's|^|@dirrm %%DATADIR%%/|' >> ${PLIST}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/sdb ${PREFIX}/bin
+ cd ${WRKSRC} && \
+ ${FIND} ${DATADIRS} -type d ! -empty -exec \
+ ${MKDIR} "${DATADIR}/{}" \; && \
+ ${FIND} ${DATADIRS} ! -type d -exec \
+ ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>