aboutsummaryrefslogtreecommitdiffstats
path: root/games/sdl_lopan
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2012-07-19 09:52:25 +0800
committerak <ak@FreeBSD.org>2012-07-19 09:52:25 +0800
commitf6ed28ad6870087a3e90833f7918dc0dfb504012 (patch)
treef5e764b7466e9ed64a8d841f2c59fe830ccf263a /games/sdl_lopan
parentd106ab43444ebfcb9b5022024f0f8b2a95101869 (diff)
downloadfreebsd-ports-gnome-f6ed28ad6870087a3e90833f7918dc0dfb504012.tar.gz
freebsd-ports-gnome-f6ed28ad6870087a3e90833f7918dc0dfb504012.tar.zst
freebsd-ports-gnome-f6ed28ad6870087a3e90833f7918dc0dfb504012.zip
- Remove the wrapper script
Approved by: nemysis <nemysis@gmx.ch> (maintainer)
Diffstat (limited to 'games/sdl_lopan')
-rw-r--r--games/sdl_lopan/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/games/sdl_lopan/Makefile b/games/sdl_lopan/Makefile
index b6b428a04624..adace3379b3b 100644
--- a/games/sdl_lopan/Makefile
+++ b/games/sdl_lopan/Makefile
@@ -30,14 +30,16 @@ PORTDOCS= Changelog README
ALL_TARGET=
+post-patch:
+# Fix data location
+ @${REINPLACE_CMD} -e 's!data/bg%d.pcx!${DATADIR}/data/bg%d.pcx!' \
+ -e 's!data/tiles%d.pcx!${DATADIR}/data/tiles%d.pcx!' \
+ -e 's!char temp\[64\];!char temp\[256\];!' \
+ ${WRKSRC}/lopan.c
+
do-install:
-# Scripts
- @${PRINTF} "#!/bin/sh\n\ncd ${DATADIR} &&\
- ./lopan\n" > ${WRKDIR}/sdllopan.sh
- @${INSTALL_SCRIPT} ${WRKDIR}/sdllopan.sh ${PREFIX}/bin/sdllopan
# Executable
- ${MKDIR} ${DATADIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/lopan ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/lopan ${PREFIX}/bin/sdllopan
# Data
@(cd ${WRKSRC} && ${COPYTREE_SHARE} data ${DATADIR})