aboutsummaryrefslogtreecommitdiffstats
path: root/games/sea-defender
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2013-09-30 01:01:41 +0800
committerzeising <zeising@FreeBSD.org>2013-09-30 01:01:41 +0800
commita8130c980c07259b8eab7b6bf3945e86793344e6 (patch)
tree108a55d148b3bc801facab0fb03b8666659c1136 /games/sea-defender
parent1c4f61d17356e9d79f6d1c39001a0f412ad79dc1 (diff)
downloadfreebsd-ports-gnome-a8130c980c07259b8eab7b6bf3945e86793344e6.tar.gz
freebsd-ports-gnome-a8130c980c07259b8eab7b6bf3945e86793344e6.tar.zst
freebsd-ports-gnome-a8130c980c07259b8eab7b6bf3945e86793344e6.zip
The FreeBSD graphics/x11 team proudly presents
a kwm, zeising production: MESA 9.1.6 Starring: Mesa 9.1.6, including libGL, libGLU and dri (new xorg only) Addition of libEGL and libglesv2 KMS support for ATI graphics cards in 10-current (new xorg only) Improved sparc64 support for new xorg. [1] pixman 0.30.2, including shlib bump and portrevision bumps libX11 1.6.2 Make absolute pointing devices work with x11-drivers/xf86-input-mouse x11-drivers/xf86-video-ati 7.2.0 for 10-current (KMS aware ati driver) Also starring: Updates to drivers and other libraries and utilities Additional notes: When updating MESA related ports (libGL, dri) you need to remove old versions first. See UPDATING for details. PR: ports/181962 [2] Submitted by: marius [1] zeising [2] Exp-run by: bdrewery Approved by: portmgr (bdrewery) Thanks to all who helped testing!
Diffstat (limited to 'games/sea-defender')
-rw-r--r--games/sea-defender/Makefile4
-rw-r--r--games/sea-defender/files/extra-snoutlib_gldefs.h11
2 files changed, 15 insertions, 0 deletions
diff --git a/games/sea-defender/Makefile b/games/sea-defender/Makefile
index ea5a3dc51ca4..bdbee8039952 100644
--- a/games/sea-defender/Makefile
+++ b/games/sea-defender/Makefile
@@ -28,6 +28,10 @@ PORTDOCS= README
NO_STAGE= yes
.include <bsd.port.options.mk>
+.if defined(WITH_NEW_XORG)
+EXTRA_PATCHES+= ${FILESDIR}/extra-snoutlib_gldefs.h
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sea ${PREFIX}/libexec/${PORTNAME}
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/bin/${PORTNAME}
diff --git a/games/sea-defender/files/extra-snoutlib_gldefs.h b/games/sea-defender/files/extra-snoutlib_gldefs.h
new file mode 100644
index 000000000000..ef24e8028c9e
--- /dev/null
+++ b/games/sea-defender/files/extra-snoutlib_gldefs.h
@@ -0,0 +1,11 @@
+--- snoutlib/gldefs.h.orig 2013-09-28 23:51:46.789551906 +0200
++++ snoutlib/gldefs.h 2013-09-28 23:52:40.941548852 +0200
+@@ -94,7 +94,7 @@
+ typedef GLboolean (GLFUNCDEF PFNGLISPROGRAMPROC) (GLuint);
+ typedef GLboolean (GLFUNCDEF PFNGLISSHADERPROC) (GLuint);
+ typedef void (GLFUNCDEF PFNGLLINKPROGRAMPROC) (GLuint);
+-typedef void (GLFUNCDEF PFNGLSHADERSOURCEPROC) (GLuint, GLsizei, const GLchar* *, const GLint *);
++typedef void (GLFUNCDEF PFNGLSHADERSOURCEPROC) (GLuint, GLsizei, const GLchar* const *, const GLint *);
+ typedef void (GLFUNCDEF PFNGLUSEPROGRAMPROC) (GLuint);
+ typedef void (GLFUNCDEF PFNGLUNIFORM1FPROC) (GLint, GLfloat);
+ typedef void (GLFUNCDEF PFNGLUNIFORM2FPROC) (GLint, GLfloat, GLfloat);