aboutsummaryrefslogtreecommitdiffstats
path: root/games/secretmaryochronicles-music
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2008-08-06 11:37:04 +0800
committeradamw <adamw@FreeBSD.org>2008-08-06 11:37:04 +0800
commit7d6998eb5b2f069a5ae50927e79a4a859cf86965 (patch)
tree4292d28add8cdd45ee2b6f0487b4b82fecfab81d /games/secretmaryochronicles-music
parent0185e94371236946ad2f33c03acc3657dd55bc40 (diff)
downloadfreebsd-ports-gnome-7d6998eb5b2f069a5ae50927e79a4a859cf86965.tar.gz
freebsd-ports-gnome-7d6998eb5b2f069a5ae50927e79a4a859cf86965.tar.zst
freebsd-ports-gnome-7d6998eb5b2f069a5ae50927e79a4a859cf86965.zip
Add a port for the background music files to Secret Maryo Chronicles
(ports/games/secretmaryochronicles). The music in this side-scrolling jump 'n run package may or may not sound suspiciously similar to another side-scrolling jump 'n run package, but YMMV.
Diffstat (limited to 'games/secretmaryochronicles-music')
-rw-r--r--games/secretmaryochronicles-music/Makefile40
-rw-r--r--games/secretmaryochronicles-music/distinfo3
-rw-r--r--games/secretmaryochronicles-music/pkg-descr4
-rw-r--r--games/secretmaryochronicles-music/pkg-plist42
4 files changed, 89 insertions, 0 deletions
diff --git a/games/secretmaryochronicles-music/Makefile b/games/secretmaryochronicles-music/Makefile
new file mode 100644
index 000000000000..d1789eef462a
--- /dev/null
+++ b/games/secretmaryochronicles-music/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: secretmaryochronicles-music
+# Date created: 5 Aug 2008
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= secretmaryochronicles-music
+PORTVERSION= 4.0
+CATEGORIES= games
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= smclone
+DISTNAME= SMC_music_${PORTVERSION}_high
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Background music for Secret Maryo Chronicles
+
+RUN_DEPENDS=smc:${PORTSDIR}/games/secretmaryochronicles
+
+USE_ZIP= yes
+
+WRKSRC= ${WRKDIR}
+DATADIR= ${PREFIX}/share/smc
+NO_BUILD= yes
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= Addon\ \-\ Music\ Readme.txt license.txt
+
+do-install:
+ ${MKDIR} ${DATADIR}/music
+ ${CP} -R ${WRKSRC}/data/music/* ${DATADIR}/music/
+
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/docs/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/secretmaryochronicles-music/distinfo b/games/secretmaryochronicles-music/distinfo
new file mode 100644
index 000000000000..b5e8f03282de
--- /dev/null
+++ b/games/secretmaryochronicles-music/distinfo
@@ -0,0 +1,3 @@
+MD5 (SMC_music_4.0_high.zip) = bb007603c723eddd6ccb007cc5f01cd6
+SHA256 (SMC_music_4.0_high.zip) = 5fd3c4b1f09a7c9ceef4b4a5e42bd3ece4278f7fbc034871478f78bd54e377b0
+SIZE (SMC_music_4.0_high.zip) = 29959059
diff --git a/games/secretmaryochronicles-music/pkg-descr b/games/secretmaryochronicles-music/pkg-descr
new file mode 100644
index 000000000000..25a2c55cb791
--- /dev/null
+++ b/games/secretmaryochronicles-music/pkg-descr
@@ -0,0 +1,4 @@
+This port installs the background music files for the side-scrolling
+jump 'n run game Secret Maryo Chronicles.
+
+WWW: http://www.secretmaryo.org/
diff --git a/games/secretmaryochronicles-music/pkg-plist b/games/secretmaryochronicles-music/pkg-plist
new file mode 100644
index 000000000000..5e1aa8cdb474
--- /dev/null
+++ b/games/secretmaryochronicles-music/pkg-plist
@@ -0,0 +1,42 @@
+%%DATADIR%%/music/game/bossbattle_3.ogg
+%%DATADIR%%/music/game/bossbattle_3.txt
+%%DATADIR%%/music/game/courseclear.ogg
+%%DATADIR%%/music/game/courseclear.txt
+%%DATADIR%%/music/game/lost_1.ogg
+%%DATADIR%%/music/game/lost_1.txt
+%%DATADIR%%/music/game/menu.ogg
+%%DATADIR%%/music/game/menu.txt
+%%DATADIR%%/music/game/star.ogg
+%%DATADIR%%/music/game/star.txt
+%%DATADIR%%/music/land/cave_1.ogg
+%%DATADIR%%/music/land/cave_1.txt
+%%DATADIR%%/music/land/cave_2.ogg
+%%DATADIR%%/music/land/cave_2.txt
+%%DATADIR%%/music/land/cave_3.ogg
+%%DATADIR%%/music/land/cave_3.txt
+%%DATADIR%%/music/land/hyper_1.ogg
+%%DATADIR%%/music/land/hyper_1.txt
+%%DATADIR%%/music/land/jungle_1.ogg
+%%DATADIR%%/music/land/jungle_1.txt
+%%DATADIR%%/music/land/land_1.ogg
+%%DATADIR%%/music/land/land_1.txt
+%%DATADIR%%/music/land/land_2.ogg
+%%DATADIR%%/music/land/land_2.txt
+%%DATADIR%%/music/land/land_3.ogg
+%%DATADIR%%/music/land/land_3.txt
+%%DATADIR%%/music/land/land_4.ogg
+%%DATADIR%%/music/land/land_4.txt
+%%DATADIR%%/music/land/land_5.ogg
+%%DATADIR%%/music/land/land_5.txt
+%%DATADIR%%/music/land/water_1.ogg
+%%DATADIR%%/music/land/water_1.txt
+%%DATADIR%%/music/land/waterway_1.ogg
+%%DATADIR%%/music/land/waterway_1.txt
+%%DATADIR%%/music/overworld/land_1.ogg
+%%DATADIR%%/music/overworld/land_1.txt
+%%DATADIR%%/music/story/default_story_1.ogg
+%%DATADIR%%/music/story/default_story_1.txt
+@dirrm %%DATADIR%%/music/story
+@dirrm %%DATADIR%%/music/overworld
+@dirrm %%DATADIR%%/music/land
+@dirrm %%DATADIR%%/music/game