aboutsummaryrefslogtreecommitdiffstats
path: root/games/senso/Makefile
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2002-01-10 14:56:50 +0800
committertrevor <trevor@FreeBSD.org>2002-01-10 14:56:50 +0800
commit70cb366a26ee15939672fa7d43d69741e95411f6 (patch)
tree5909e857f33737bb9044265c52c64b4d3515ad07 /games/senso/Makefile
parent91dc6e1e9d81abbf3cd66528b9f156ff414e4a55 (diff)
downloadfreebsd-ports-gnome-70cb366a26ee15939672fa7d43d69741e95411f6.tar.gz
freebsd-ports-gnome-70cb366a26ee15939672fa7d43d69741e95411f6.tar.zst
freebsd-ports-gnome-70cb366a26ee15939672fa7d43d69741e95411f6.zip
new port of senso, a game which challenges short-term memory
Diffstat (limited to 'games/senso/Makefile')
-rw-r--r--games/senso/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/games/senso/Makefile b/games/senso/Makefile
new file mode 100644
index 000000000000..629dd04a460a
--- /dev/null
+++ b/games/senso/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: senso
+# Date created: 2002-01-09
+# Whom: trevor
+#
+# $FreeBSD$
+#
+
+PORTNAME= senso
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= http://stud.fbi.fh-darmstadt.de/~koenig/pub/
+EXTRACT_SUFX= .py
+
+MAINTAINER= trevor@FreeBSD.org
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+
+USE_PYTHON= yes
+NO_BUILD= yes
+PLIST= ${WRKDIR}/pkg-plist
+WRKSRC= ${WRKDIR}
+
+do-extract:
+ ${MKDIR} ${WRKDIR}
+
+pre-install:
+ ${ECHO} "bin/senso" > ${PLIST}
+
+do-install:
+ ${INSTALL_SCRIPT} ${_DISTDIR}/${DISTFILES} ${PREFIX}/bin/senso
+
+.include <bsd.port.mk>