aboutsummaryrefslogtreecommitdiffstats
path: root/games/shaaft/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-01-03 05:33:26 +0800
committerkrion <krion@FreeBSD.org>2004-01-03 05:33:26 +0800
commitb1cd99f1eb39aaf7482aa720449c5f26db12b3a6 (patch)
tree635edd2a2779f20906fec412c389b2c58483dd42 /games/shaaft/Makefile
parenta8e020409d388c7d17f4c3bd60882cb3ec4767c4 (diff)
downloadfreebsd-ports-gnome-b1cd99f1eb39aaf7482aa720449c5f26db12b3a6.tar.gz
freebsd-ports-gnome-b1cd99f1eb39aaf7482aa720449c5f26db12b3a6.tar.zst
freebsd-ports-gnome-b1cd99f1eb39aaf7482aa720449c5f26db12b3a6.zip
Shaaft is an OpenGL 3D falling block game similar to Blockout.
Diffstat (limited to 'games/shaaft/Makefile')
-rw-r--r--games/shaaft/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/games/shaaft/Makefile b/games/shaaft/Makefile
new file mode 100644
index 000000000000..0029619ef22d
--- /dev/null
+++ b/games/shaaft/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: shaaft
+# Date created: 02 Jan 2004
+# Whom: krion@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= shaaft
+PORTVERSION= 0.5.0
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= sourceforge/criticalmass
+DISTNAME= Shaaft-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Shaaft is an OpenGL 3D falling block game similar to Blockout
+
+LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
+ SDL_image.10:${PORTSDIR}/graphics/sdl_image
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_SDL= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+MAN6= ${PORTNAME}.6
+
+.include <bsd.port.mk>