aboutsummaryrefslogtreecommitdiffstats
path: root/games/shootingstar
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-10-19 10:58:40 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-10-19 10:58:40 +0800
commit99d21637c40ebe452f4f57aa7bdf4a002c0cf6c9 (patch)
treea6d3bac965fd3f09cc404bc4e8927215937d16a3 /games/shootingstar
parent5914e713b44bc02a277924f0131cd253508e2f51 (diff)
downloadfreebsd-ports-gnome-99d21637c40ebe452f4f57aa7bdf4a002c0cf6c9.tar.gz
freebsd-ports-gnome-99d21637c40ebe452f4f57aa7bdf4a002c0cf6c9.tar.zst
freebsd-ports-gnome-99d21637c40ebe452f4f57aa7bdf4a002c0cf6c9.zip
- Support staging
- Convert USE_GMAKE to USES - Fix segfault - Rename patches according to porter's handbook
Diffstat (limited to 'games/shootingstar')
-rw-r--r--games/shootingstar/Makefile6
-rw-r--r--games/shootingstar/files/patch-src-engine-cTextureFont.cpp (renamed from games/shootingstar/files/patch-src--engine--cTextureFont.cpp)0
-rw-r--r--games/shootingstar/files/patch-src-game-cMainMenu.cpp11
-rw-r--r--games/shootingstar/files/patch-src-game-cOptions.cpp (renamed from games/shootingstar/files/patch-src--game--cOptions.cpp)0
-rw-r--r--games/shootingstar/pkg-plist119
5 files changed, 15 insertions, 121 deletions
diff --git a/games/shootingstar/Makefile b/games/shootingstar/Makefile
index 0f43d1ed2fa5..f28bb5eef9cc 100644
--- a/games/shootingstar/Makefile
+++ b/games/shootingstar/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= SDL/OpenGL top-down shooter
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
USE_GL= gl
USE_SDL= sdl mixer image
@@ -20,5 +20,7 @@ CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
+PLIST_FILES= bin/${PORTNAME}
+PORTDATA= *
+
.include <bsd.port.mk>
diff --git a/games/shootingstar/files/patch-src--engine--cTextureFont.cpp b/games/shootingstar/files/patch-src-engine-cTextureFont.cpp
index 8bb271989363..8bb271989363 100644
--- a/games/shootingstar/files/patch-src--engine--cTextureFont.cpp
+++ b/games/shootingstar/files/patch-src-engine-cTextureFont.cpp
diff --git a/games/shootingstar/files/patch-src-game-cMainMenu.cpp b/games/shootingstar/files/patch-src-game-cMainMenu.cpp
new file mode 100644
index 000000000000..161dc7eb369a
--- /dev/null
+++ b/games/shootingstar/files/patch-src-game-cMainMenu.cpp
@@ -0,0 +1,11 @@
+--- src/game/cMainMenu.cpp.orig 2004-02-21 15:48:50.000000000 +0300
++++ src/game/cMainMenu.cpp 2013-10-19 04:20:28.484773573 +0400
+@@ -399,7 +399,7 @@
+
+ string &text = mDemoStrings[mCurrentString];
+
+- static unsigned int i = 0;
++ static int i = 0;
+ if ( mLastLetter + 100 < now )
+ {
+ i++;
diff --git a/games/shootingstar/files/patch-src--game--cOptions.cpp b/games/shootingstar/files/patch-src-game-cOptions.cpp
index 085646cf8e84..085646cf8e84 100644
--- a/games/shootingstar/files/patch-src--game--cOptions.cpp
+++ b/games/shootingstar/files/patch-src-game-cOptions.cpp
diff --git a/games/shootingstar/pkg-plist b/games/shootingstar/pkg-plist
deleted file mode 100644
index 3cce62049f7f..000000000000
--- a/games/shootingstar/pkg-plist
+++ /dev/null
@@ -1,119 +0,0 @@
-bin/shootingstar
-%%DATADIR%%/animations/bloodpool
-%%DATADIR%%/animations/enemy_shoot
-%%DATADIR%%/animations/enemy_stand
-%%DATADIR%%/animations/enemy_walk
-%%DATADIR%%/animations/enemy_wshoot
-%%DATADIR%%/animations/gibs
-%%DATADIR%%/animations/medpack
-%%DATADIR%%/animations/player1_shoot
-%%DATADIR%%/animations/player1_stand
-%%DATADIR%%/animations/player1_walk
-%%DATADIR%%/animations/player1_wshoot
-%%DATADIR%%/animations/player2_shoot
-%%DATADIR%%/animations/player2_stand
-%%DATADIR%%/animations/player2_walk
-%%DATADIR%%/animations/player2_wshoot
-%%DATADIR%%/animations/rocket
-%%DATADIR%%/animations/weaponbox
-%%DATADIR%%/maps/city.map
-%%DATADIR%%/maps/city.obj
-%%DATADIR%%/maps/factory.map
-%%DATADIR%%/maps/factory.obj
-%%DATADIR%%/maps/highway.map
-%%DATADIR%%/maps/highway.obj
-%%DATADIR%%/maps/levels
-%%DATADIR%%/maps/office.map
-%%DATADIR%%/maps/office.obj
-%%DATADIR%%/maps/park.map
-%%DATADIR%%/maps/park.obj
-%%DATADIR%%/maps/test.map
-%%DATADIR%%/maps/test.obj
-%%DATADIR%%/maps/village.map
-%%DATADIR%%/maps/village.obj
-%%DATADIR%%/maps/warehouse.map
-%%DATADIR%%/maps/warehouse.obj
-%%DATADIR%%/shootingstar.cfg
-%%DATADIR%%/sounds/bazookareload.wav
-%%DATADIR%%/sounds/burning.wav
-%%DATADIR%%/sounds/dead.ogg
-%%DATADIR%%/sounds/death.wav
-%%DATADIR%%/sounds/empty.wav
-%%DATADIR%%/sounds/explosion.wav
-%%DATADIR%%/sounds/flamer.wav
-%%DATADIR%%/sounds/hit.wav
-%%DATADIR%%/sounds/hurt.wav
-%%DATADIR%%/sounds/machinegun.wav
-%%DATADIR%%/sounds/menu.ogg
-%%DATADIR%%/sounds/pickup.wav
-%%DATADIR%%/sounds/pistol.wav
-%%DATADIR%%/sounds/reload.wav
-%%DATADIR%%/sounds/rocket.wav
-%%DATADIR%%/sounds/shotgun.wav
-%%DATADIR%%/sounds/shotgunreload.wav
-%%DATADIR%%/textures/ammobox.png
-%%DATADIR%%/textures/archive.png
-%%DATADIR%%/textures/archive_open.png
-%%DATADIR%%/textures/barrel.png
-%%DATADIR%%/textures/barrel1.png
-%%DATADIR%%/textures/barrel2.png
-%%DATADIR%%/textures/bitmaps.png
-%%DATADIR%%/textures/blood1.png
-%%DATADIR%%/textures/blood2.png
-%%DATADIR%%/textures/blood3.png
-%%DATADIR%%/textures/blood4.png
-%%DATADIR%%/textures/blood_big1.png
-%%DATADIR%%/textures/blood_big2.png
-%%DATADIR%%/textures/body1.png
-%%DATADIR%%/textures/body2.png
-%%DATADIR%%/textures/concrete.png
-%%DATADIR%%/textures/enemy.png
-%%DATADIR%%/textures/floor1.png
-%%DATADIR%%/textures/floor2.png
-%%DATADIR%%/textures/font_11x20.png
-%%DATADIR%%/textures/gibs.png
-%%DATADIR%%/textures/grass.png
-%%DATADIR%%/textures/ground.png
-%%DATADIR%%/textures/hear.png
-%%DATADIR%%/textures/hud_p1.png
-%%DATADIR%%/textures/hud_p2.png
-%%DATADIR%%/textures/laatikko1.png
-%%DATADIR%%/textures/laatikko2.png
-%%DATADIR%%/textures/laatikko3.png
-%%DATADIR%%/textures/laatikko4.png
-%%DATADIR%%/textures/laatikko4_p.png
-%%DATADIR%%/textures/laatikko_p.png
-%%DATADIR%%/textures/logo_left.png
-%%DATADIR%%/textures/logo_right.png
-%%DATADIR%%/textures/mainmenu.png
-%%DATADIR%%/textures/medpak.png
-%%DATADIR%%/textures/menu_selector.png
-%%DATADIR%%/textures/pipe.png
-%%DATADIR%%/textures/player1.png
-%%DATADIR%%/textures/player2.png
-%%DATADIR%%/textures/poyta.png
-%%DATADIR%%/textures/poyta2.png
-%%DATADIR%%/textures/road.png
-%%DATADIR%%/textures/smoke.png
-%%DATADIR%%/textures/stonefloor.png
-%%DATADIR%%/textures/stones1.png
-%%DATADIR%%/textures/stones2.png
-%%DATADIR%%/textures/stones3.png
-%%DATADIR%%/textures/suer.png
-%%DATADIR%%/textures/toilet_clean.png
-%%DATADIR%%/textures/toilet_dirty.png
-%%DATADIR%%/textures/track.png
-%%DATADIR%%/textures/treetop1.png
-%%DATADIR%%/textures/tuli2.png
-%%DATADIR%%/textures/tuoli.png
-%%DATADIR%%/textures/wall_32.png
-%%DATADIR%%/textures/warning.png
-%%DATADIR%%/textures/wcfloor.png
-%%DATADIR%%/textures/weam.png
-%%DATADIR%%/textures/weaponlogos.png
-%%DATADIR%%/textures/woodfloor.png
-@dirrm %%DATADIR%%/animations
-@dirrm %%DATADIR%%/maps
-@dirrm %%DATADIR%%/sounds
-@dirrm %%DATADIR%%/textures
-@dirrm %%DATADIR%%