aboutsummaryrefslogtreecommitdiffstats
path: root/games/simutrans/Makefile
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-07-28 16:12:06 +0800
committertobik <tobik@FreeBSD.org>2018-07-28 16:12:06 +0800
commit842a8d0ef6fabe823e69b42635dcd4c8c75e19bd (patch)
tree066d579890f2a09f631d9819f0d390a8c885ada4 /games/simutrans/Makefile
parentce5908aa3d243089b7ed70edb88a0764471b7c01 (diff)
downloadfreebsd-ports-gnome-842a8d0ef6fabe823e69b42635dcd4c8c75e19bd.tar.gz
freebsd-ports-gnome-842a8d0ef6fabe823e69b42635dcd4c8c75e19bd.tar.zst
freebsd-ports-gnome-842a8d0ef6fabe823e69b42635dcd4c8c75e19bd.zip
games/simutrans: Fix build with Clang 6
gui/simwin.cc:503:11: error: case value evaluates to -1, which cannot be narrowed to type 'uint32' (aka 'unsigned int') [-Wc++11-narrowing] case magic_none: return; ^ http://beefy12.nyi.freebsd.org/data/head-amd64-default/p475044_s336572/logs/simutrans-120.2.2.log - While here apply dos2unix and fix patch line endings
Diffstat (limited to 'games/simutrans/Makefile')
-rw-r--r--games/simutrans/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/games/simutrans/Makefile b/games/simutrans/Makefile
index d9d397311fa9..0982b33b6fe7 100644
--- a/games/simutrans/Makefile
+++ b/games/simutrans/Makefile
@@ -37,9 +37,12 @@ MAKE_ARGS= BACKEND=mixer_sdl \
FLAGS="-DUSE_C -DREVISION=${SIMUTRANS_REVISION}" \
VERBOSE=1
NO_WRKSUBDIR= yes
-USES= gmake zip
+USES= compiler dos2unix gmake zip
USE_SDL= sdl mixer
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
+DOS2UNIX_GLOB= *
DESKTOP_ENTRIES=Simutrans "" "" simutrans "Game;Simulation;" false
PLIST_FILES= bin/simutrans bin/simutrans-bin
PORTDATA= *