aboutsummaryrefslogtreecommitdiffstats
path: root/games/solarwolf
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-06-25 22:57:21 +0800
committersobomax <sobomax@FreeBSD.org>2001-06-25 22:57:21 +0800
commit81e5b1f86d4c1b37e6dfc6de7c9a5706dd7c83dc (patch)
tree154b51f5b80351f403ba5694a7a5cb8b1287d20d /games/solarwolf
parente7e2797c31b036c4040e881f107f873870cf330b (diff)
downloadfreebsd-ports-gnome-81e5b1f86d4c1b37e6dfc6de7c9a5706dd7c83dc.tar.gz
freebsd-ports-gnome-81e5b1f86d4c1b37e6dfc6de7c9a5706dd7c83dc.tar.zst
freebsd-ports-gnome-81e5b1f86d4c1b37e6dfc6de7c9a5706dd7c83dc.zip
Use "exec" statement in the helper script to avoid leaving useless sh instance
hanging around.
Diffstat (limited to 'games/solarwolf')
-rw-r--r--games/solarwolf/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/games/solarwolf/Makefile b/games/solarwolf/Makefile
index a7213636a225..9216ea84f41e 100644
--- a/games/solarwolf/Makefile
+++ b/games/solarwolf/Makefile
@@ -24,7 +24,7 @@ do-install:
(cd ${WRKSRC}; tar cf - .) | \
(cd ${PREFIX}/share/solarwolf; tar --unlink -xf -)
@printf "#!/bin/sh\ncd ${PREFIX}/share/solarwolf && \
- ${PYTHON_CMD} ${PREFIX}/share/solarwolf/solarwolf.py\n" > ${WRKDIR}/solarwolf.sh
+ exec ${PYTHON_CMD} ${PREFIX}/share/solarwolf/solarwolf.py\n" > ${WRKDIR}/solarwolf.sh
@${INSTALL_SCRIPT} ${WRKDIR}/solarwolf.sh ${PREFIX}/bin/solarwolf
.include <bsd.port.mk>