aboutsummaryrefslogtreecommitdiffstats
path: root/games/spellathon
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-10-13 21:03:03 +0800
committermakc <makc@FreeBSD.org>2013-10-13 21:03:03 +0800
commita24b5a9439576d52b7a1e94d6c4dd3f0e5d8c13e (patch)
tree9d348bd41c93dc07e16d63761a277862fca2beec /games/spellathon
parent59c0a46aa2540ee31e961d5f970ecb9f7804f01e (diff)
downloadfreebsd-ports-gnome-a24b5a9439576d52b7a1e94d6c4dd3f0e5d8c13e.tar.gz
freebsd-ports-gnome-a24b5a9439576d52b7a1e94d6c4dd3f0e5d8c13e.tar.zst
freebsd-ports-gnome-a24b5a9439576d52b7a1e94d6c4dd3f0e5d8c13e.zip
- Convert unmaintained ports to USES=qmake
- Add stage support - Convert LIB_DEPENDS to new syntax - Minor changes/fixes
Diffstat (limited to 'games/spellathon')
-rw-r--r--games/spellathon/Makefile38
1 files changed, 18 insertions, 20 deletions
diff --git a/games/spellathon/Makefile b/games/spellathon/Makefile
index b3bf3fbf03e8..4bad8c8372d9 100644
--- a/games/spellathon/Makefile
+++ b/games/spellathon/Makefile
@@ -12,41 +12,39 @@ COMMENT= Word game to test your English vocabulary skills
LICENSE= BSD
-LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
- pcre:${PORTSDIR}/devel/pcre \
- png15:${PORTSDIR}/graphics/png \
- freetype:${PORTSDIR}/print/freetype2 \
- expat:${PORTSDIR}/textproc/expat2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig
+LIB_DEPENDS= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
+ libpcre.so:${PORTSDIR}/devel/pcre \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
CXXFLAGS+= -fPIC
-USES= gettext iconv
+USES= gettext iconv qmake
USE_GNOME= glib20
USE_QT4= corelib gui moc_build qmake_build rcc_build uic_build
USE_XORG= ice sm x11 xau xcb xdmcp xext xrender
USE_LDCONFIG= yes
+CONFIGURE_WRKSRC= ${WRKSRC}/src/gui
+
DESKTOP_ENTRIES="Spellathon" "${COMMENT}" "" "${PORTNAME}" "Education;Languages;" "true"
-NO_STAGE= yes
post-patch:
@${FIND} ${WRKSRC} -name "Makefile" | ${XARGS} ${REINPLACE_CMD} -e \
's|$${CC}|$${CXX}|g ; \
- s|$${CFLAGS}|$${CXXFLAGS}|g ; \
- s|qmake-qt4|${TRUE}|'
+ s|$${CFLAGS}|$${CXXFLAGS}|g ; \
+ s|qmake-qt4|${TRUE}|'
@${REINPLACE_CMD} \
's|dict/words.txt|${DATADIR}/words.txt|' ${WRKSRC}/src/logic/defines.h
-do-configure:
- @(cd ${WRKSRC}/src/gui && ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKEFLAGS})
-
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/spellathon ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/spellathon-cl ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/libspellathon.so.0.0 ${PREFIX}/lib
- ${LN} -sf libspellathon.so.0.0 ${PREFIX}/lib/libspellathon.so
- ${LN} -sf libspellathon.so.0.0 ${PREFIX}/lib/libspellathon.so.0
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/dict/words.txt ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/spellathon ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/spellathon-cl ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/libspellathon.so.0.0 ${STAGEDIR}${PREFIX}/lib
+ ${LN} -sf libspellathon.so.0.0 ${STAGEDIR}${PREFIX}/lib/libspellathon.so
+ ${LN} -sf libspellathon.so.0.0 ${STAGEDIR}${PREFIX}/lib/libspellathon.so.0
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/dict/words.txt ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>