aboutsummaryrefslogtreecommitdiffstats
path: root/games/spider
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2011-07-06 13:18:35 +0800
committerstephen <stephen@FreeBSD.org>2011-07-06 13:18:35 +0800
commit6136320a4e5288aa3b174f48565aab725fb17e1c (patch)
treeb2ead4eadffdd98ed8d78abf15cd6467c33010d5 /games/spider
parent26ce08be48d35a32cf1c065587d7cffd73bb5a5c (diff)
downloadfreebsd-ports-gnome-6136320a4e5288aa3b174f48565aab725fb17e1c.tar.gz
freebsd-ports-gnome-6136320a4e5288aa3b174f48565aab725fb17e1c.tar.zst
freebsd-ports-gnome-6136320a4e5288aa3b174f48565aab725fb17e1c.zip
- Fix segfault on amd64.
- Bump portrevision. PR: ports/150287 Submitted by: Pascal Stumpf <Pascal.Stumpf@cubes.de> and Shaun Amott <shaun@FreeBSD.org> Approved by: maho (mentor)
Diffstat (limited to 'games/spider')
-rw-r--r--games/spider/Makefile2
-rw-r--r--games/spider/files/patch-ad8
2 files changed, 6 insertions, 4 deletions
diff --git a/games/spider/Makefile b/games/spider/Makefile
index 381c865fd0f3..010f1703b034 100644
--- a/games/spider/Makefile
+++ b/games/spider/Makefile
@@ -7,7 +7,7 @@
PORTNAME= spider
PORTVERSION= 1.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= games/solitaires
diff --git a/games/spider/files/patch-ad b/games/spider/files/patch-ad
index 1f8abcba60ab..203be244bd95 100644
--- a/games/spider/files/patch-ad
+++ b/games/spider/files/patch-ad
@@ -1,6 +1,6 @@
---- globals.h.orig Sun Sep 29 02:26:08 2002
-+++ globals.h Sun Sep 29 02:26:23 2002
-@@ -96,6 +96,8 @@
+--- globals.h.orig 1991-09-28 17:46:20.000000000 +0000
++++ globals.h 2011-07-01 03:25:27.000000000 +0000
+@@ -96,6 +96,10 @@
Bool can_get_help_files();
#endif
@@ -8,4 +8,6 @@
extern char *malloc();
extern char *calloc();
extern char *realloc();
++#else
++#include <stdlib.h>
+#endif