aboutsummaryrefslogtreecommitdiffstats
path: root/games/stepmania-devel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-07 21:12:31 +0800
committerbapt <bapt@FreeBSD.org>2013-05-07 21:12:31 +0800
commitc51dc118d16532cbb0975f6a1283f79f0f639846 (patch)
tree5522ebdbbbc41a02fbc8bf3da8fa96b3719b6d61 /games/stepmania-devel
parentd6971706dddb262040a6508b9b7e08ba636e3147 (diff)
downloadfreebsd-ports-gnome-c51dc118d16532cbb0975f6a1283f79f0f639846.tar.gz
freebsd-ports-gnome-c51dc118d16532cbb0975f6a1283f79f0f639846.tar.zst
freebsd-ports-gnome-c51dc118d16532cbb0975f6a1283f79f0f639846.zip
Add some shebangfix to allow building most of the ports tree without /usr/bin/perl
Submitted by: John Marino Obtained from: DPorts
Diffstat (limited to 'games/stepmania-devel')
-rw-r--r--games/stepmania-devel/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/games/stepmania-devel/Makefile b/games/stepmania-devel/Makefile
index 43a18565ba9a..c42eb9dae646 100644
--- a/games/stepmania-devel/Makefile
+++ b/games/stepmania-devel/Makefile
@@ -28,13 +28,15 @@ PROJECTHOST= sm-ssc
USE_BZIP2= yes
USE_XORG= x11 xau xdmcp xext xrandr xrender xtst
USE_GL= gl glu
-USES= pathfix iconv
+USES= pathfix iconv shebangfix
USE_GNOME= gtk20
USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-ffmpeg
INSTALLS_ICONS= yes
MAKE_JOBS_SAFE= yes
+SHEBANG_FILES= Utils/*.pl \
+ extern/zlib/zlib2ansi
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib