aboutsummaryrefslogtreecommitdiffstats
path: root/games/stockfish
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-09-13 21:51:42 +0800
committerdanfe <danfe@FreeBSD.org>2015-09-13 21:51:42 +0800
commit0c5704cbd21fff7470be9ae1776ed54869a5372c (patch)
treeaf6bbcc49d65a3cc0b31dfdad2a55ef004b84db2 /games/stockfish
parent40f43c108ac91275d0da7b1aca4babd3cc4b5931 (diff)
downloadfreebsd-ports-gnome-0c5704cbd21fff7470be9ae1776ed54869a5372c.tar.gz
freebsd-ports-gnome-0c5704cbd21fff7470be9ae1776ed54869a5372c.tar.zst
freebsd-ports-gnome-0c5704cbd21fff7470be9ae1776ed54869a5372c.zip
- Limit Tier-2 unsupported systems list to sparc64: PowerPC is supported
(both 32- and 64-bit), and there's little reason to mention ia64 as it is being officially killed in -CURRENT some time ago and we don't make any packages for it anyways - Rename options POPCNT_ENABLED -> POPCNT and PROFILE_BUILD -> PROFILE; not just it makes more sense, it also allows to use shared description text (PROFILE_DESC) - Place PORTDATA and PORTDOCS right below PLIST_FILES where they belong - Organize knobs in a more natural way, use `do-install-DOCS-on' target, mute MKDIR's, improve and kill EOL whitespace in the port description text, sort USES values, and fix some minor style issues while I'm here
Diffstat (limited to 'games/stockfish')
-rw-r--r--games/stockfish/Makefile58
-rw-r--r--games/stockfish/pkg-descr14
2 files changed, 36 insertions, 36 deletions
diff --git a/games/stockfish/Makefile b/games/stockfish/Makefile
index ab6273353ebd..618239fc4b7e 100644
--- a/games/stockfish/Makefile
+++ b/games/stockfish/Makefile
@@ -7,69 +7,71 @@ CATEGORIES= games
MASTER_SITES= http://stockfish.s3.amazonaws.com/:src \
http://cl.ly/3x333m0G173F/download/:book \
http://www.execve.net/sf/:book
-DISTNAME= stockfish-${PORTVERSION}-src
-DISTFILES= stockfish-${PORTVERSION}-src.zip:src \
- stockfish-231-book.zip:book
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+DISTFILES= ${PORTNAME}-${PORTVERSION}-src.zip:src \
+ ${PORTNAME}-231-book.zip:book
MAINTAINER= execve@gmail.com
COMMENT= Open source chess engine
LICENSE= GPLv3
+NOT_FOR_ARCHS= sparc64
+
+USES= compiler gmake zip
+
WRKSRC= ${WRKDIR}/${DISTNAME}/src
-USES= gmake compiler zip
-MYARCH= ${ARCH}
BOOKDIR= .
-PORTDOCS= Readme.md polyglot.ini
-PORTDATA= Book.bin
+MYARCH= ${ARCH}
+MYCC= ${COMPILER_TYPE}
+TGTBLD= build
PLIST_FILES= bin/stockfish
+PORTDATA= Book.bin
+PORTDOCS= Readme.md polyglot.ini
-TGTBLD= build
-MYCC= ${COMPILER_TYPE}
+OPTIONS_DEFINE= DOCS POPCNT PROFILE
-OPTIONS_DEFINE= DOCS POPCNT_ENABLED PROFILE_BUILD
-POPCNT_ENABLED_DESC= Use the POPCNT instruction
-PROFILE_BUILD_DESC= Make a Profile build
+POPCNT_DESC= Use the POPCNT instruction
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MPROFILE_BUILD}
+.if ${PORT_OPTIONS:MPROFILE}
TGTBLD= profile-build
.endif
-.if ${PORT_OPTIONS:MPOPCNT_ENABLED}
-.if ${ARCH} != "amd64"
-BROKEN= POPCNT_ENABLED compiles only on amd64
-.endif
+.if ${PORT_OPTIONS:MPOPCNT} && ${ARCH} != amd64
+BROKEN= POPCNT compiles only on amd64
.endif
# workaround the ARCH usage in the stockfish Makefile
.if ${ARCH} == "i386"
MYARCH= x86-32
.elif ${ARCH} == "amd64"
-.if ${PORT_OPTIONS:MPOPCNT_ENABLED}
+. if ${PORT_OPTIONS:MPOPCNT}
MYARCH= x86-64-modern
-.else
+. else
MYARCH= x86-64
+. endif
+.elif ${ARCH} == powerpc
+MYARCH= ppc-32
+.elif ${ARCH} == powerpc64
+MYARCH= ppc-64
.endif
-.endif
-ALL_TARGET= ${TGTBLD} ARCH=${MYARCH} COMP=${MYCC}
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64, powerpc, or sparc64
-.endif
+ALL_TARGET= ${TGTBLD} ARCH=${MYARCH} COMP=${MYCC}
post-patch:
@${REINPLACE_CMD} -e "s/^PREFIX =/PREFIX ?=/" ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/stockfish ${STAGEDIR}${PREFIX}/bin/stockfish
+ ${INSTALL_PROGRAM} ${WRKSRC}/stockfish ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKDIR}/${BOOKDIR}/${PORTDATA} ${STAGEDIR}${DATADIR}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/Readme.md ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/polyglot.ini ${STAGEDIR}${DOCSDIR}
- ${MKDIR} ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} ${WRKDIR}/${BOOKDIR}/${PORTDATA} ${STAGEDIR}${DATADIR}/
.include <bsd.port.mk>
diff --git a/games/stockfish/pkg-descr b/games/stockfish/pkg-descr
index 174ec8a5130c..996517f98e25 100644
--- a/games/stockfish/pkg-descr
+++ b/games/stockfish/pkg-descr
@@ -1,11 +1,9 @@
-Stockfish is a free UCI chess engine derived from Glaurung 2.1. It is
-not a complete chess program and requires some UCI-compatible GUI
-(e.g. XBoard with PolyGlot, eboard, Arena, Sigma Chess, Shredder, Chess
-Partner or Fritz) in order to be used comfortably. Read the
-documentation for your GUI of choice for information about how to use
-Stockfish with it.
+Stockfish is a free UCI chess engine derived from Glaurung 2.1. It is not
+a complete chess program and requires some UCI-compatible GUI (e.g. XBoard
+with PolyGlot, eboard, Arena, Sigma Chess, Shredder, Chess Partner, or
+Fritz) in order to be used comfortably.
-Stockfish is free and uses the GPL license. You can download, read,
-and modify the source code.
+Read the documentation for your GUI of choice for information about how to
+use Stockfish with it.
WWW: http://www.stockfishchess.com/