aboutsummaryrefslogtreecommitdiffstats
path: root/games/stockfish
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-09-17 01:37:14 +0800
committermadpilot <madpilot@FreeBSD.org>2013-09-17 01:37:14 +0800
commit7cdeae401e34c33169345a987605b95cef774515 (patch)
treee776449d72b55fb4eb5dd6f9670f19474bf19e8c /games/stockfish
parente5596801d431ca5d9459342e7ff647dfc6f364ef (diff)
downloadfreebsd-ports-gnome-7cdeae401e34c33169345a987605b95cef774515.tar.gz
freebsd-ports-gnome-7cdeae401e34c33169345a987605b95cef774515.tar.zst
freebsd-ports-gnome-7cdeae401e34c33169345a987605b95cef774515.zip
- Fix build with clang
- Make it respect PREFIX - While here, USES=gmake PR: ports/181616 Submitted by: Me Approved by: Maintainer timeout
Diffstat (limited to 'games/stockfish')
-rw-r--r--games/stockfish/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/games/stockfish/Makefile b/games/stockfish/Makefile
index ed99a8e9d50c..780c520f043b 100644
--- a/games/stockfish/Makefile
+++ b/games/stockfish/Makefile
@@ -19,7 +19,7 @@ LICENSE= GPLv3
USE_ZIP= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/src
-USE_GMAKE= yes
+USES= gmake
MYARCH= ${ARCH}
BOOKDIR= .
PORTDOCS= Readme.txt polyglot.ini
@@ -69,6 +69,13 @@ ALL_TARGET= ${TGTBLD} ARCH=${MYARCH} COMP=${MYCC}
BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
+.if exists(/usr/bin/clang) && ${OSVERSION} > 1000024
+MYCC= clang
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s/^PREFIX =/PREFIX ?=/" ${WRKSRC}/Makefile
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/stockfish ${PREFIX}/bin/stockfish