aboutsummaryrefslogtreecommitdiffstats
path: root/games/supertux/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-04-17 13:45:46 +0800
committerkrion <krion@FreeBSD.org>2004-04-17 13:45:46 +0800
commit3b30130aeb734a7f4c88b4979485eaa434182220 (patch)
tree7bf03b2a26f7ba43932c133828f554016cb86199 /games/supertux/Makefile
parentc99e3e55a2be6f336487fc92f96d86068990803d (diff)
downloadfreebsd-ports-gnome-3b30130aeb734a7f4c88b4979485eaa434182220.tar.gz
freebsd-ports-gnome-3b30130aeb734a7f4c88b4979485eaa434182220.tar.zst
freebsd-ports-gnome-3b30130aeb734a7f4c88b4979485eaa434182220.zip
Add supertux 0.0.6,
Super Tux is a side-scrolling run-and-jump game with a level editor similar to the original game "Super Mario Bros." from the Nintendo Entertainment System. PR: ports/65650 Submitted by: michael johnson <ahze at ahze dot net>
Diffstat (limited to 'games/supertux/Makefile')
-rw-r--r--games/supertux/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/games/supertux/Makefile b/games/supertux/Makefile
new file mode 100644
index 000000000000..e5c5c5c0930c
--- /dev/null
+++ b/games/supertux/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: supertux
+# Date created: 2004-04-17
+# Whom: michael johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= supertux
+PORTVERSION= 0.0.6
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= super-tux
+
+MAINTAINER= ahze@ahze.net
+COMMENT= Super Tux is a side-scroller similar to Super Mario Brothers
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+WANT_SDL= yes
+USE_SDL= image
+USE_GL= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --disable-debug
+OPTIONS= SOUND "SDL mixer (audio) support" on
+USE_REINPLACE= yes
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_SOUND)
+CONFIGURE_ARGS+=--disable-sound
+.else
+USE_SDL+= mixer
+PLIST_SUB+= SOUND=""
+.endif
+
+post-patch:
+.if defined(WITHOUT_SOUND)
+ @${RM} -f ${WRKSRC}/data/sounds/* ${WRKSRC}/data/music/*
+.endif
+ @${REINPLACE_CMD} -e 's|SDL/|SDL11/|' \
+ ${WRKSRC}/src/type.h
+
+.include <bsd.port.post.mk>