aboutsummaryrefslogtreecommitdiffstats
path: root/games/supertux/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-05-14 15:57:57 +0800
committerkrion <krion@FreeBSD.org>2004-05-14 15:57:57 +0800
commitb8bc22e125070b1fd81ee8c5496a2a16be5958bb (patch)
tree3f6cc7354cc531b2fb55bf022f7e6383930ad560 /games/supertux/Makefile
parentc76c2cc1c2283a2486a7adde39f7c6c62d3ad179 (diff)
downloadfreebsd-ports-gnome-b8bc22e125070b1fd81ee8c5496a2a16be5958bb.tar.gz
freebsd-ports-gnome-b8bc22e125070b1fd81ee8c5496a2a16be5958bb.tar.zst
freebsd-ports-gnome-b8bc22e125070b1fd81ee8c5496a2a16be5958bb.zip
- Update to 0.1.1
PR: ports/66627 Submitted by: maintainer
Diffstat (limited to 'games/supertux/Makefile')
-rw-r--r--games/supertux/Makefile15
1 files changed, 2 insertions, 13 deletions
diff --git a/games/supertux/Makefile b/games/supertux/Makefile
index 82f75a37094d..79e72161c077 100644
--- a/games/supertux/Makefile
+++ b/games/supertux/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= supertux
-PORTVERSION= 0.1.0
+PORTVERSION= 0.1.1
CATEGORIES= games
MASTER_SITES= http://pingus.seul.org/~grumbel/tmp/ \
${MASTER_SITE_SOURCEFORGE}
@@ -18,28 +18,17 @@ COMMENT= Super Tux is a side-scroller similar to Super Mario Brothers
USE_X_PREFIX= yes
USE_BZIP2= yes
WANT_SDL= yes
-USE_SDL= image
+USE_SDL= image mixer
USE_GL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --disable-debug
-OPTIONS= SOUND "SDL mixer (audio) support" on
USE_REINPLACE= yes
.include <bsd.port.pre.mk>
-.if defined(WITHOUT_SOUND)
-CONFIGURE_ARGS+=--disable-sound
-.else
-USE_SDL+= mixer
-PLIST_SUB+= SOUND=""
-.endif
-
post-patch:
-.if defined(WITHOUT_SOUND)
- @${RM} -f ${WRKSRC}/data/sounds/* ${WRKSRC}/data/music/*
-.endif
@${REINPLACE_CMD} -e 's|SDL/|SDL11/|' \
${WRKSRC}/src/type.h