aboutsummaryrefslogtreecommitdiffstats
path: root/games/tads
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2005-10-16 12:09:34 +0800
committerkris <kris@FreeBSD.org>2005-10-16 12:09:34 +0800
commit33c5a697c1a49e2ec197a63f2547a53920380360 (patch)
treed9c13c66318fa911459074bef38f0b0850942d05 /games/tads
parent24e168dc7a3ef24119b327af500cc68c7fae38d0 (diff)
downloadfreebsd-ports-gnome-33c5a697c1a49e2ec197a63f2547a53920380360.tar.gz
freebsd-ports-gnome-33c5a697c1a49e2ec197a63f2547a53920380360.tar.zst
freebsd-ports-gnome-33c5a697c1a49e2ec197a63f2547a53920380360.zip
Roll our own do-install target to make this port PREFIX-friendly.
Diffstat (limited to 'games/tads')
-rw-r--r--games/tads/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/games/tads/Makefile b/games/tads/Makefile
index 219bbef772ff..2f5aa72fa860 100644
--- a/games/tads/Makefile
+++ b/games/tads/Makefile
@@ -16,4 +16,13 @@ COMMENT= TADS compiler/interpreter for interactive fiction
WRKSRC= ${WRKDIR}/tads-3.0.8/tads2
+do-install:
+ ${MKDIR} ${PREFIX}/share/tads2
+.for i in tadsc tadsr tdb
+ ${INSTALL_PROGRAM} ${WRKSRC}/$i ${PREFIX}/bin
+.endfor
+.for i in adv.t std.t gameinfo.t
+ ${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/share/tads2
+.endfor
+
.include <bsd.port.mk>