aboutsummaryrefslogtreecommitdiffstats
path: root/games/tank/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-03-14 20:20:49 +0800
committersobomax <sobomax@FreeBSD.org>2001-03-14 20:20:49 +0800
commit112c04523fa6569b3e691b6d805a2643dbb7edb5 (patch)
treeeae642c7b5913774e86c46ef35299eab2f2b554b /games/tank/Makefile
parent5e1436150c7102861fcd3e5b155b9f980608e921 (diff)
downloadfreebsd-ports-gnome-112c04523fa6569b3e691b6d805a2643dbb7edb5.tar.gz
freebsd-ports-gnome-112c04523fa6569b3e691b6d805a2643dbb7edb5.tar.zst
freebsd-ports-gnome-112c04523fa6569b3e691b6d805a2643dbb7edb5.zip
o Fix the port after it has been broken for ages (since Mesa3 release);
o make it CFLAGS/X11BASE and PREFIX-clean; o install data files into ${PREFIX}/share, not into ${PREFIX}/lib as it was previously. Prompted by: bento
Diffstat (limited to 'games/tank/Makefile')
-rw-r--r--games/tank/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/games/tank/Makefile b/games/tank/Makefile
index dd420482d416..84ed8f426318 100644
--- a/games/tank/Makefile
+++ b/games/tank/Makefile
@@ -11,18 +11,18 @@ CATEGORIES= games
MASTER_SITES= http://step.polymtl.ca/~coyote/tank/
DISTFILES= ${DISTNAME}-src.tar.gz
-MAINTAINER= dburr@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
-BROKEN= can\'t find glaux.h
+BUILD_DEPENDS= ${X11BASE}/lib/libaux.a:${PORTSDIR}/graphics/libaux
-USE_MESA= YES
-USE_GMAKE= YES
+USE_MESA= yes
+USE_GMAKE= yes
ALL_TARGET= linux-mesa-elf
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tank ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/lib/tank
- ${INSTALL_DATA} ${WRKSRC}/*.tga ${PREFIX}/lib/tank
- ${INSTALL_DATA} ${WRKSRC}/*.au ${PREFIX}/lib/tank
+ ${MKDIR} ${PREFIX}/share/tank
+ ${INSTALL_DATA} ${WRKSRC}/*.tga ${PREFIX}/share/tank
+ ${INSTALL_DATA} ${WRKSRC}/*.au ${PREFIX}/share/tank
.include <bsd.port.mk>