aboutsummaryrefslogtreecommitdiffstats
path: root/games/teg/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-08-28 15:28:07 +0800
committersobomax <sobomax@FreeBSD.org>2002-08-28 15:28:07 +0800
commit85c6880e3eb6f0c8f275c3c60a101e0ef09ab96d (patch)
tree13635c5c494935377286b9761681824f029b70db /games/teg/Makefile
parent5710eb98774292a90f2e02ef6169abd72f0a9b58 (diff)
downloadfreebsd-ports-gnome-85c6880e3eb6f0c8f275c3c60a101e0ef09ab96d.tar.gz
freebsd-ports-gnome-85c6880e3eb6f0c8f275c3c60a101e0ef09ab96d.tar.zst
freebsd-ports-gnome-85c6880e3eb6f0c8f275c3c60a101e0ef09ab96d.zip
Update to 0.9.4.
Diffstat (limited to 'games/teg/Makefile')
-rw-r--r--games/teg/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/games/teg/Makefile b/games/teg/Makefile
index ccae29426844..63c4de788e8d 100644
--- a/games/teg/Makefile
+++ b/games/teg/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= teg
-PORTVERSION= 0.9.2
+PORTVERSION= 0.9.4
CATEGORIES= games gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,18 +15,16 @@ MAINTAINER= sobomax@FreeBSD.org
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
- @find ${WRKSRC} -name "*.[ch]" -type f | xargs ${PERL} -pi -e \
+ @find ${WRKSRC} -name "*.[ch]" -type f | xargs ${REINPLACE_CMD} -e \
's|LIST_NEXT|TEG_LIST_NEXT|g'
.include <bsd.port.mk>