aboutsummaryrefslogtreecommitdiffstats
path: root/games/tesseract
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-03-16 00:27:41 +0800
committerjbeich <jbeich@FreeBSD.org>2016-03-16 00:27:41 +0800
commit406dcc236e3dcf3cbf44c5d0c1102a0ed8b9fe10 (patch)
tree94654cd729d1fa1e185e4c3cbfacc94011b6709e /games/tesseract
parent2a35cdbce83783ab2c249d5eeaf4b9b07924faa4 (diff)
downloadfreebsd-ports-gnome-406dcc236e3dcf3cbf44c5d0c1102a0ed8b9fe10.tar.gz
freebsd-ports-gnome-406dcc236e3dcf3cbf44c5d0c1102a0ed8b9fe10.tar.zst
freebsd-ports-gnome-406dcc236e3dcf3cbf44c5d0c1102a0ed8b9fe10.zip
games/tesseract{,-data}: add new port
PR: 189829 (based on) Submitted by: operator@myrechenzentrum.net Reviewed by: marino (partially, earlier version) Tesseract is a first-person shooter game focused on instagib deathmatch and capture-the-flag gameplay as well as cooperative in-game map editing. http://www.tesseract.gg
Diffstat (limited to 'games/tesseract')
-rw-r--r--games/tesseract/Makefile75
-rw-r--r--games/tesseract/distinfo2
-rw-r--r--games/tesseract/files/tess_wrapper.in4
-rw-r--r--games/tesseract/pkg-descr10
4 files changed, 91 insertions, 0 deletions
diff --git a/games/tesseract/Makefile b/games/tesseract/Makefile
new file mode 100644
index 000000000000..0743a233cb36
--- /dev/null
+++ b/games/tesseract/Makefile
@@ -0,0 +1,75 @@
+# $FreeBSD$
+
+PORTNAME= tesseract
+DISTVERSION= 2014_05_12
+CATEGORIES= games
+MASTER_SITES= http://download.tuxfamily.org/${PORTNAME}/
+PKGNAMESUFFIX= -game
+DISTNAME= ${PORTNAME}_${DISTVERSION}_first_edition_linux
+
+MAINTAINER= operator@myrechenzentrum.net
+COMMENT= Smooth FPS with map editing, instagib, DM and CTF
+
+LICENSE= ZLIB
+
+LIB_DEPENDS= libenet.so:net/enet
+RUN_DEPENDS= ${PKGBASE}-data>=${DISTVERSION}:${PKGORIGIN}-data
+
+USES= gmake pkgconfig tar:xz
+EXCLUDE= bin_unix config media screenshot src/enet src/lib\* src/xcode
+EXTRACT_AFTER_ARGS=${EXCLUDE:S,^,--exclude ,}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+BUILD_WRKSRC= ${WRKSRC}/src
+ALL_TARGET= # empty
+SUB_FILES= tess_wrapper
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT=CLIENT DEDICATED
+OPTIONS_MULTI= FLAVOR
+OPTIONS_MULTI_FLAVOR=CLIENT DEDICATED MASTER
+
+CLIENT_DESC= Build client
+CLIENT_USE= GL=gl SDL=image2,mixer2 XORG=x11
+CLIENT_ALL_TARGET= client
+CLIENT_PLIST_FILES= bin/tess_client libexec/tess_client
+CLIENT_DESKTOP_ENTRIES= "Tesseract" \
+ "" \
+ "${DATADIR}/media/interface/cube.png" \
+ "tess_client" \
+ "Game;Shooter;" \
+ ""
+
+DEDICATED_DESC= Build dedicated server
+DEDICATED_ALL_TARGET= server
+DEDICATED_PLIST_FILES= bin/tess_server libexec/tess_server
+
+MASTER_DESC= Build master server
+MASTER_ALL_TARGET= master
+MASTER_PLIST_FILES= bin/tess_master libexec/tess_master
+
+post-patch:
+ @${REINPLACE_CMD} -e '/OBJS.*PCH/d' \
+ -e '/-fomit-frame-pointer/d' \
+ -e 's,-I/usr/X11R6/include,,' \
+ -e 's,-L/usr/X11R6/lib,,' \
+ -e 's,libenet ,,' \
+ -e 's,-Ienet/include,`pkg-config --cflags libenet`,' \
+ -e 's,-Lenet -lenet,`pkg-config --libs libenet`,' \
+ ${BUILD_WRKSRC}/Makefile
+
+do-install:
+ for f in ${PLIST_FILES:Mbin/*}; do \
+ ${INSTALL_SCRIPT} ${WRKDIR}/tess_wrapper \
+ ${STAGEDIR}${PREFIX}/$$f; \
+ done
+ for f in ${PLIST_FILES:Mlibexec/*}; do \
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/$${f##*/} \
+ ${STAGEDIR}${PREFIX}/$${f%/*}; \
+ done
+
+do-install-DOCS-on:
+ (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \
+ . ${STAGEDIR}${DOCSDIR})
+
+.include <bsd.port.mk>
diff --git a/games/tesseract/distinfo b/games/tesseract/distinfo
new file mode 100644
index 000000000000..106ac8dc6b20
--- /dev/null
+++ b/games/tesseract/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tesseract_2014_05_12_first_edition_linux.tar.xz) = 8d6e07dd154a40a3f593e52289335c036f06cf90a0ebc400c4650adb3395a0f4
+SIZE (tesseract_2014_05_12_first_edition_linux.tar.xz) = 249009328
diff --git a/games/tesseract/files/tess_wrapper.in b/games/tesseract/files/tess_wrapper.in
new file mode 100644
index 000000000000..8aa8c0b1522e
--- /dev/null
+++ b/games/tesseract/files/tess_wrapper.in
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd ${TESS_DATA="%%DATADIR%%"}
+exec %%PREFIX%%/libexec/${0##*/} ${TESS_OPTIONS="-u~/.tesseract"} "$@"
diff --git a/games/tesseract/pkg-descr b/games/tesseract/pkg-descr
new file mode 100644
index 000000000000..e52fa9a5b59a
--- /dev/null
+++ b/games/tesseract/pkg-descr
@@ -0,0 +1,10 @@
+Tesseract is a first-person shooter game focused on instagib deathmatch
+and capture-the-flag gameplay as well as cooperative in-game map editing.
+
+Tesseract provides a unique open-source engine derived from Cube 2
+Sauerbraten technology but with upgraded modern rendering techniques.
+The new rendering features include fully dynamic omnidirectional
+shadows, global illumination, HDR lighting, deferred shading,
+morphological/temporal/multisample anti-aliasing, and much more.
+
+WWW: http://www.tesseract.gg