aboutsummaryrefslogtreecommitdiffstats
path: root/games/tetrons/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-12-22 04:20:28 +0800
committermiwi <miwi@FreeBSD.org>2006-12-22 04:20:28 +0800
commit587f57f92fae6b4ff826936eec68e4af9f575a0b (patch)
tree1cee276699134d92df4bde8eaf4f63b8562d120f /games/tetrons/Makefile
parent23bbecc2ab45b7a18442c10d223ac0f5e31e78c1 (diff)
downloadfreebsd-ports-gnome-587f57f92fae6b4ff826936eec68e4af9f575a0b.tar.gz
freebsd-ports-gnome-587f57f92fae6b4ff826936eec68e4af9f575a0b.tar.zst
freebsd-ports-gnome-587f57f92fae6b4ff826936eec68e4af9f575a0b.zip
This is a version of the popular falling-block game from the eighties which
requires only Xlib to build and run. PR: ports/106942 Submitted by: James Bailie <jimmy at mammothcheese.ca>
Diffstat (limited to 'games/tetrons/Makefile')
-rw-r--r--games/tetrons/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/games/tetrons/Makefile b/games/tetrons/Makefile
new file mode 100644
index 000000000000..28c947241576
--- /dev/null
+++ b/games/tetrons/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: tetrons
+# Date created: Tue, Dec 19 2006 15:00:38 EST
+# Whom: James Bailie <jimmy@mammothcheese.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tetrons
+PORTVERSION= 1.2
+CATEGORIES= games
+MASTER_SITES= http://www.mammothcheese.ca/
+
+MAINTAINER= jimmy@mammothcheese.ca
+COMMENT= Tetris(TM) clone for X11
+
+MAKE_ARGS+= -DRANDOM
+USE_XLIB= yes
+
+PLIST_FILES= bin/tetrons
+
+.include <bsd.port.mk>