aboutsummaryrefslogtreecommitdiffstats
path: root/games/textmaze/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-09-09 05:24:03 +0800
committerijliao <ijliao@FreeBSD.org>2001-09-09 05:24:03 +0800
commit2c5fe4b7b4014d9f6ab61b587d73ed8e7ae0189d (patch)
treee2b2c3a45cad34941b3288384cc6f5595b5a3f92 /games/textmaze/Makefile
parent859773e13b6d3613f6038391f83ac9a1e95819b2 (diff)
downloadfreebsd-ports-gnome-2c5fe4b7b4014d9f6ab61b587d73ed8e7ae0189d.tar.gz
freebsd-ports-gnome-2c5fe4b7b4014d9f6ab61b587d73ed8e7ae0189d.tar.zst
freebsd-ports-gnome-2c5fe4b7b4014d9f6ab61b587d73ed8e7ae0189d.zip
add textmaze
Generates mazes on a text terminal and lets you traverse them
Diffstat (limited to 'games/textmaze/Makefile')
-rw-r--r--games/textmaze/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/games/textmaze/Makefile b/games/textmaze/Makefile
new file mode 100644
index 000000000000..71612c05f135
--- /dev/null
+++ b/games/textmaze/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# New ports collection makefile for: textmaze
+# Date created: Sep 8, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= textmaze
+PORTVERSION= 0.5
+CATEGORIES= games perl5
+MASTER_SITES= http://www.robobunny.com/projects/textmaze/
+DISTNAME= ${PORTNAME}_v${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PERL5= yes
+WRKSRC= ${WRKDIR}/TextMaze
+NO_BUILD= yes
+
+post-patch:
+ @${PERL} -pi -e "s,/usr/local/bin/perl,${PERL},g" ${WRKSRC}/textmaze
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/textmaze ${PREFIX}/bin
+
+.include <bsd.port.mk>