aboutsummaryrefslogtreecommitdiffstats
path: root/games/textmaze
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2013-05-07 16:42:29 +0800
committerehaupt <ehaupt@FreeBSD.org>2013-05-07 16:42:29 +0800
commit3a6dc725ca1faf0ff9b9fc3271320d4d363fb978 (patch)
tree8a88caff05c37366ca99d8d7a8bf0e00aedaf6ce /games/textmaze
parentcd2bc69ed74ae79a66b9b9a431fab33eb63d5ab6 (diff)
downloadfreebsd-ports-gnome-3a6dc725ca1faf0ff9b9fc3271320d4d363fb978.tar.gz
freebsd-ports-gnome-3a6dc725ca1faf0ff9b9fc3271320d4d363fb978.tar.zst
freebsd-ports-gnome-3a6dc725ca1faf0ff9b9fc3271320d4d363fb978.zip
Convert to use shebangfix USES flag.
Diffstat (limited to 'games/textmaze')
-rw-r--r--games/textmaze/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/games/textmaze/Makefile b/games/textmaze/Makefile
index f5dd5c80920d..646a56ffe442 100644
--- a/games/textmaze/Makefile
+++ b/games/textmaze/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: textmaze
-# Date created: Sep 8, 2001
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= textmaze
PORTVERSION= 1.2
@@ -18,17 +13,15 @@ COMMENT= Generates mazes on a text terminal and lets you traverse them
RUN_DEPENDS= p5-Curses>=0:${PORTSDIR}/devel/p5-Curses
+USES= shebangfix
USE_PERL5= yes
NO_BUILD= yes
+SHEBANG_FILES= textmaze
PLIST_FILES= bin/textmaze
WRKSRC= ${WRKDIR}/TextMaze
-post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local/bin/perl|${PERL}|' \
- ${WRKSRC}/${PORTNAME}
-
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin