aboutsummaryrefslogtreecommitdiffstats
path: root/games/tksol/files
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1995-07-04 18:25:20 +0800
committerasami <asami@FreeBSD.org>1995-07-04 18:25:20 +0800
commit4aa19b2c69fc4f893421216bf2c23dccaf3ef27e (patch)
tree84b7d75f14e0e292f03208435f578ea581324984 /games/tksol/files
parent752ee554e230e91b53fcf4ad6541d54a1c45d93b (diff)
downloadfreebsd-ports-gnome-4aa19b2c69fc4f893421216bf2c23dccaf3ef27e.tar.gz
freebsd-ports-gnome-4aa19b2c69fc4f893421216bf2c23dccaf3ef27e.tar.zst
freebsd-ports-gnome-4aa19b2c69fc4f893421216bf2c23dccaf3ef27e.zip
A Tk version of xsol.
Submitted by: Thomas Gellekum <thomas@ghpc8.ihf.rwth-aachen.de>
Diffstat (limited to 'games/tksol/files')
-rw-r--r--games/tksol/files/patch-a77
1 files changed, 77 insertions, 0 deletions
diff --git a/games/tksol/files/patch-a b/games/tksol/files/patch-a
new file mode 100644
index 000000000000..12e1e74137de
--- /dev/null
+++ b/games/tksol/files/patch-a
@@ -0,0 +1,77 @@
+diff -cr tksol-0.9.orig/Makefile tksol-0.9/Makefile
+*** tksol-0.9.orig/Makefile Fri Jan 7 21:30:02 1994
+--- tksol-0.9/Makefile Sun Jun 25 19:28:08 1995
+***************
+*** 7,13 ****
+ CHMOD = chmod
+ ECHO = echo
+ MKDIR = mkdir -p
+! INSTALL = install -c -m 644
+
+ BINSCRIPT = -e 's+@cardbitmaps@+$(CARDBITMAPS)+g' \
+ -e 's+@downbitmaps@+$(DOWNBITMAPS)+g' \
+--- 7,13 ----
+ CHMOD = chmod
+ ECHO = echo
+ MKDIR = mkdir -p
+! INSTALL = install -c -m 644 -g bin -o bin
+
+ BINSCRIPT = -e 's+@cardbitmaps@+$(CARDBITMAPS)+g' \
+ -e 's+@downbitmaps@+$(DOWNBITMAPS)+g' \
+***************
+*** 19,45 ****
+ ############################################
+ # Absolute pathname of the wish executable #
+ ############################################
+! WISH = /usr/imports/bin/wish
+
+ ####################################################
+ # Directory where the script tksol will be located #
+ ####################################################
+! BINDIR = /homes/bao/src/test/tksol
+
+ #####################################################
+ # Directory where the tksol manpage will be located #
+ #####################################################
+! MANDIR = /homes/bao/src/man
+
+ ####################################################################
+ # Directory where the bitmaps for the faceup cards will be located #
+ ####################################################################
+! CARDBITMAPS = /homes/bao/src/test/tksol/cardbitmaps
+
+ ######################################################################
+ # Directory where the bitmaps for the facedown cards will be located #
+ ######################################################################
+! DOWNBITMAPS = /homes/bao/src/test/tksol/downbitmaps
+
+
+ all: tksol tksol.1
+--- 19,45 ----
+ ############################################
+ # Absolute pathname of the wish executable #
+ ############################################
+! WISH = ${PREFIX}/bin/wish
+
+ ####################################################
+ # Directory where the script tksol will be located #
+ ####################################################
+! BINDIR = ${PREFIX}/bin
+
+ #####################################################
+ # Directory where the tksol manpage will be located #
+ #####################################################
+! MANDIR = ${PREFIX}/man/man1
+
+ ####################################################################
+ # Directory where the bitmaps for the faceup cards will be located #
+ ####################################################################
+! CARDBITMAPS = ${PREFIX}/lib/tk/tksol/cardbitmaps
+
+ ######################################################################
+ # Directory where the bitmaps for the facedown cards will be located #
+ ######################################################################
+! DOWNBITMAPS = ${PREFIX}/lib/tk/tksol/downbitmaps
+
+
+ all: tksol tksol.1