aboutsummaryrefslogtreecommitdiffstats
path: root/games/tmw
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /games/tmw
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'games/tmw')
-rw-r--r--games/tmw/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/games/tmw/Makefile b/games/tmw/Makefile
index 3841a6396dab..83c5a47a41c5 100644
--- a/games/tmw/Makefile
+++ b/games/tmw/Makefile
@@ -25,7 +25,7 @@ RUN_DEPENDS= guichan>=0.8.1:${PORTSDIR}/devel/guichan
GNU_CONFIGURE= yes
USE_SDL= sdl image mixer net ttf
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include `${SDL_CONFIG} --cflags` ${PTHREAD_CFLAGS}"
+CPPFLAGS+= -I${LOCALBASE}/include `${SDL_CONFIG} --cflags` ${PTHREAD_CFLAGS}
MAN6= tmw.6
OPTIONS= MUSIC "Install additional music" on \
@@ -35,11 +35,11 @@ OPTIONS= MUSIC "Install additional music" on \
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
-CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} -lintl"
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lintl
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
-CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.endif
.if !defined(WITHOUT_MUSIC)