aboutsummaryrefslogtreecommitdiffstats
path: root/games/tome4
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-08-03 23:11:27 +0800
committeradamw <adamw@FreeBSD.org>2014-08-03 23:11:27 +0800
commitadddf7945540a1b967c1b7fdd709ac2abaf27da3 (patch)
tree88514abc24e3f2d265c313074c815cfd7d53bd31 /games/tome4
parent3bc3e3fb28085a0bb3bb2cf577f87858af47d2a2 (diff)
downloadfreebsd-ports-gnome-adddf7945540a1b967c1b7fdd709ac2abaf27da3.tar.gz
freebsd-ports-gnome-adddf7945540a1b967c1b7fdd709ac2abaf27da3.tar.zst
freebsd-ports-gnome-adddf7945540a1b967c1b7fdd709ac2abaf27da3.zip
This fixes games/tome4 after devel/premake4 update to 4.4-beta5
The new premake4 seems to hardcode "gcc" regardless of CC, command line flags, etc., and not in a way environment for gmake can override this. The patch fixes output of premake4 before running gmake. It a no-op on systems with premake4 4.3 and doesn't change the package on systems where tome4 already builds. PR: 192291 Palindromic PR: yes Submitted by: maintainer
Diffstat (limited to 'games/tome4')
-rw-r--r--games/tome4/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/games/tome4/Makefile b/games/tome4/Makefile
index e152ed24b7ec..21ef1d687585 100644
--- a/games/tome4/Makefile
+++ b/games/tome4/Makefile
@@ -31,12 +31,10 @@ USE_CSTD= gnu89
SUB_FILES= tome4
MAKE_JOBS_UNSAFE=yes
-post-patch:
- @${REINPLACE_CMD} -e 's|gcc|${CC}|' ${WRKSRC}/src/lua/Makefile \
- ${WRKSRC}/src/luabitop/Makefile ${WRKSRC}/build/te4core.lua
pre-build:
@${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/premake4.lua
(cd ${WRKSRC} && premake4 gmake)
+ @${REINPLACE_CMD} 's|gcc|${CC}|' ${WRKSRC}/build/*.make
@${REINPLACE_CMD} 's|-lpthread|-pthread|' ${WRKSRC}/build/TEngine.make
do-install: