aboutsummaryrefslogtreecommitdiffstats
path: root/games/toppler/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2002-04-03 00:43:40 +0800
committerdinoex <dinoex@FreeBSD.org>2002-04-03 00:43:40 +0800
commitc5374af57b740fa19cb5af898706f0fadae21b7a (patch)
tree9ea5633dfa8ff5fd00c6e1ea19f4abbbb22a9890 /games/toppler/Makefile
parentd70126eede102a6608d1e0ebc5583d83a551fd84 (diff)
downloadfreebsd-ports-gnome-c5374af57b740fa19cb5af898706f0fadae21b7a.tar.gz
freebsd-ports-gnome-c5374af57b740fa19cb5af898706f0fadae21b7a.tar.zst
freebsd-ports-gnome-c5374af57b740fa19cb5af898706f0fadae21b7a.zip
toppler (aka nebulous) is a game where you have to guide a small
frog up a tower, avoiding the baddies. You do have a snowball to fire, though. PR: 34119 Submitted by: dom@happygiraffe.net
Diffstat (limited to 'games/toppler/Makefile')
-rw-r--r--games/toppler/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/games/toppler/Makefile b/games/toppler/Makefile
new file mode 100644
index 000000000000..48f09f4744a7
--- /dev/null
+++ b/games/toppler/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: toppler
+# Date created: 18 Jan 2002
+# Whom: Dom Mitchell <dom@happygiraffe.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= toppler
+PORTVERSION= 0.71
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= toppler
+
+MAINTAINER= dom@happygiraffe.net
+
+LIB_DEPENDS= SDL-1.1:${PORTSDIR}/devel/sdl12
+
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+
+SCOREDIR?= /var/games/${PORTNAME}
+SCOREFILE?= ${PORTNAME}.hscr
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @find ${WRKSRC} \( -name "*.[ch]" -or -name "*.cc" \) | \
+ xargs ${PERL} -pi -e 's|"SDL/SDL|"SDL|g ; s|<SDL/SDL|<SDL|g'
+
+post-patch:
+ @${PERL} -pi -e 's|%SCOREDIR%|${SCOREDIR}|g;' \
+ -e 's|%SCOREFILE%|${SCOREFILE}|g' ${WRKSRC}/menu.cc
+
+pre-install:
+ ${MKDIR} ${SCOREDIR}
+
+post-install:
+ ${CHOWN} root:games ${PREFIX}/bin/${PORTNAME}
+ ${CHMOD} g+s ${PREFIX}/bin/${PORTNAME}
+ ${TOUCH} ${SCOREDIR}/${SCOREFILE}
+ ${CHMOD} 664 ${SCOREDIR}/${SCOREFILE}
+ ${CHOWN} root:games ${SCOREDIR}/${SCOREFILE}
+
+.include <bsd.port.mk>