aboutsummaryrefslogtreecommitdiffstats
path: root/games/torcs
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-01-06 04:36:33 +0800
committerpav <pav@FreeBSD.org>2009-01-06 04:36:33 +0800
commit460836ff23b6dcedf0492f75495022dc42f6eb99 (patch)
tree5c97de462ec70569d72e34d640782d1b9348d6de /games/torcs
parentfbbcbe4a59e1074c58bbdabf056cd9c13db27392 (diff)
downloadfreebsd-ports-gnome-460836ff23b6dcedf0492f75495022dc42f6eb99.tar.gz
freebsd-ports-gnome-460836ff23b6dcedf0492f75495022dc42f6eb99.tar.zst
freebsd-ports-gnome-460836ff23b6dcedf0492f75495022dc42f6eb99.zip
- Remove conditional checks for FreeBSD 5.x and older
Diffstat (limited to 'games/torcs')
-rw-r--r--games/torcs/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/games/torcs/Makefile b/games/torcs/Makefile
index b8a0db575d12..2b6c86fe9573 100644
--- a/games/torcs/Makefile
+++ b/games/torcs/Makefile
@@ -26,6 +26,9 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
REINPLACE_ARGS= -i ""
CONFIGURE_ARGS= --x-includes=${LOCALBASE}/include --x-libraries=${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include -DHAVE_DECL_GETOPT" \
+ LIBS="${PTHREAD_LIBS}" LDFLAGS="${LDFLAGS}"
+
ALL_TARGET= default
INSTALL_TARGET= install datainstall
@@ -47,13 +50,6 @@ BASH2FIX= src/linux/torcs.in src/tools/accc/accc.in \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500041
-CPPFLAGS+= -I${LOCALBASE}/include
-.else
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include -DHAVE_DECL_GETOPT" \
- LIBS="${PTHREAD_LIBS}" LDFLAGS="${LDFLAGS}"
-.endif
-
.if defined(WITH_FREEGLUT)
LIB_DEPENDS+= glut.11:${PORTSDIR}/graphics/freeglut
.else