aboutsummaryrefslogtreecommitdiffstats
path: root/games/torcs
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-02-16 05:50:19 +0800
committerkrion <krion@FreeBSD.org>2004-02-16 05:50:19 +0800
commitc67ac63b4529820c9ff97edabb165ce72200b53b (patch)
treea4c2a997afdc94c4e43088049318a7de485a1081 /games/torcs
parentb87d7b44f985119c077248905d91c2fbdf87209a (diff)
downloadfreebsd-ports-gnome-c67ac63b4529820c9ff97edabb165ce72200b53b.tar.gz
freebsd-ports-gnome-c67ac63b4529820c9ff97edabb165ce72200b53b.tar.zst
freebsd-ports-gnome-c67ac63b4529820c9ff97edabb165ce72200b53b.zip
- Fix build on 5.x and unbreak this port
PR: ports/62887 Submitted by: Thierry Thomas <thierry@pompo.net>
Diffstat (limited to 'games/torcs')
-rw-r--r--games/torcs/Makefile4
-rw-r--r--games/torcs/files/patch-src::drivers::K1999::K1999.cpp28
2 files changed, 28 insertions, 4 deletions
diff --git a/games/torcs/Makefile b/games/torcs/Makefile
index c752694617c4..9f209aa3e6d7 100644
--- a/games/torcs/Makefile
+++ b/games/torcs/Makefile
@@ -73,10 +73,6 @@ PLIST_SUB+= K1999="@comment "
BASH2FIX= src/modules/telemetry/telemetry.sh src/tools/launcher/torcs.in \
Make-default.mk robotgen \
-.if ${OSVERSION} >= 502000
-BROKEN= "Does not compile"
-.endif
-
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} " You might define these options:"
diff --git a/games/torcs/files/patch-src::drivers::K1999::K1999.cpp b/games/torcs/files/patch-src::drivers::K1999::K1999.cpp
new file mode 100644
index 000000000000..5adfe77559b9
--- /dev/null
+++ b/games/torcs/files/patch-src::drivers::K1999::K1999.cpp
@@ -0,0 +1,28 @@
+--- src/drivers/K1999/K1999.cpp.orig Sat Apr 19 11:48:14 2003
++++ src/drivers/K1999/K1999.cpp Sun Feb 15 21:32:27 2004
+@@ -14,8 +14,15 @@
+ ////////////////////////////////////////////////////////////////////////////
+ #include <iostream.h>
+ #ifndef WIN32
++
++#if defined(__GNUC__) && __GNUC__ > 2
++#include <strstream>
++#else
+ #include <strstream.h>
+-#endif
++#endif // __GNUC__
++
++#endif // WIN32
++
+ #include <iomanip.h>
+ #include <math.h>
+ #include <stdlib.h>
+@@ -515,7 +522,7 @@
+ OUTPUT("initTrack(" << index << ")");
+ char szSettings[100];
+ #ifndef WIN32
+- ostrstream os(szSettings, sizeof(szSettings));
++ std::ostrstream os(szSettings, sizeof(szSettings));
+ os << "drivers/K1999/" << index << "/settings.xml" << ends;
+ #else
+ sprintf(szSettings, "drivers/K1999/%d/settings.xml", index);