aboutsummaryrefslogtreecommitdiffstats
path: root/games/tremor
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /games/tremor
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'games/tremor')
-rw-r--r--games/tremor/Makefile7
-rw-r--r--games/tremor/files/patch-Makefile21
2 files changed, 16 insertions, 12 deletions
diff --git a/games/tremor/Makefile b/games/tremor/Makefile
index 5e9dad92aca9..8bd425d70f11 100644
--- a/games/tremor/Makefile
+++ b/games/tremor/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tremor
PORTVERSION= 3.2.4.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= http://qudos.quakedev.com/linux/quake1/:src \
http://tremor.quakedev.com/:data
@@ -25,9 +25,8 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
EXTRACT_DEPENDS=unzip:${PORTSDIR}/archivers/unzip
USE_BZIP2= yes
-USE_GCC= 3.4+
-USE_GL= gl
-USE_XORG= xxf86dga
+USE_GL= gl glu
+USE_XORG= x11 xxf86dga
USE_GMAKE= yes
ALL_TARGET= release
diff --git a/games/tremor/files/patch-Makefile b/games/tremor/files/patch-Makefile
index 64c76ac1849d..033c8838a70d 100644
--- a/games/tremor/files/patch-Makefile
+++ b/games/tremor/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig Wed Jan 17 06:19:35 2007
-+++ Makefile Wed Feb 14 15:40:17 2007
-@@ -21,51 +21,44 @@
+--- ./Makefile.orig 2007-01-17 10:19:35.000000000 +0100
++++ ./Makefile 2008-04-13 17:38:19.000000000 +0200
+@@ -21,51 +21,42 @@
BUILD_DEBUG_DIR=debug_build
BUILD_RELEASE_DIR=release_build
@@ -40,7 +40,6 @@
-X11BASE=/usr/X11R6
+LOCALBASE?=/usr/local
+GAMEBASE=$(LOCALBASE)
-+X11BASE?=/usr/X11R6
SYSBINDIR=$(LOCALBASE)/bin
-DATADIR= $(GAMEBASE)/games/quake
-
@@ -54,7 +53,7 @@
-BASE_CFLAGS+= \
+BASE_CFLAGS+= $(CFLAGS) \
-I$(LOCALBASE)/include \
- -I$(X11BASE)/include \
+- -I$(X11BASE)/include \
-Dstricmp=strcasecmp \
-DGLQUAKE
-ifeq ($(ARCH),i386)
@@ -65,7 +64,7 @@
DEBUG_CFLAGS=$(BASE_CFLAGS) -g -ggdb -Wall
RELEASE_CFLAGS+=$(BASE_CFLAGS) \
-fno-strict-aliasing \
-@@ -76,9 +69,6 @@
+@@ -76,9 +67,6 @@
-falign-loops=2 \
-falign-jumps=2 \
-falign-functions=2
@@ -75,7 +74,13 @@
endif
ifeq ($(strip $(STRIP)),YES)
-@@ -107,7 +97,7 @@
+@@ -102,12 +90,11 @@
+
+ X_LDFLAGS=-L$(X11BASE)/lib$(ARCH_LIBDIR) \
+ -lX11 -lXext -lXxf86vm -lXxf86dga
+-GLX_LDFLAGS=-L$(X11BASE)/lib$(ARCH_LIBDIR) \
+- -L$(LOCALBASE)/lib$(ARCH_LIBDIR) \
++GLX_LDFLAGS=-L$(LOCALBASE)/lib$(ARCH_LIBDIR) \
-lGL -lGLU -ljpeg `libpng-config --libs`
@@ -84,7 +89,7 @@
SDL_CFLAGS=$(shell $(SDL_CONFIG) --cflags)
SDL_LDFLAGS=$(shell $(SDL_CONFIG) --libs)
-@@ -405,4 +395,4 @@
+@@ -405,4 +392,4 @@
@echo
@printf "Type tremor as user to start playing.\n"
@echo .....