aboutsummaryrefslogtreecommitdiffstats
path: root/games/tremulous
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2010-01-26 03:15:18 +0800
committerpav <pav@FreeBSD.org>2010-01-26 03:15:18 +0800
commitdfee6d5c62ab6b269042d70b16ee7a2529db951e (patch)
treebe83fbf870c86e4040bbca6fff53505cd1e7c8e2 /games/tremulous
parent4c40a810f99571b1f539a6fbd7c3a13147bb82c0 (diff)
downloadfreebsd-ports-gnome-dfee6d5c62ab6b269042d70b16ee7a2529db951e.tar.gz
freebsd-ports-gnome-dfee6d5c62ab6b269042d70b16ee7a2529db951e.tar.zst
freebsd-ports-gnome-dfee6d5c62ab6b269042d70b16ee7a2529db951e.zip
- Introduce USE_OPENAL variable for OpenAL consumers
- Switch to openal-soft as a default OpenAL implementation PR: ports/142123 Submitted by: mva Tested by: pointyhat exp-run Approved by: portmgr (hat)
Diffstat (limited to 'games/tremulous')
-rw-r--r--games/tremulous/Makefile4
-rw-r--r--games/tremulous/files/patch-src_client_snd_openal.c11
2 files changed, 13 insertions, 2 deletions
diff --git a/games/tremulous/Makefile b/games/tremulous/Makefile
index 0a2ba04ec6ae..f186e2cfc22e 100644
--- a/games/tremulous/Makefile
+++ b/games/tremulous/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tremulous
PORTVERSION= 1.1.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/1.1 \
http://0day.icculus.org/mirrors/tremulous/ \
@@ -59,7 +59,7 @@ MAKE_ENV+= HAVE_VM_COMPILED=true
.if !defined(WITHOUT_CLIENT) || !defined(WITHOUT_SMP)
# OpenAL
. if defined(WITH_OPENAL)
-LIB_DEPENDS+= openal.0:${PORTSDIR}/audio/openal
+USE_OPENAL= al
MAKE_ENV+= USE_OPENAL=1
. if defined(WITH_OPENAL_DLOPEN)
MAKE_ENV+= USE_OPENAL_DLOPEN=1
diff --git a/games/tremulous/files/patch-src_client_snd_openal.c b/games/tremulous/files/patch-src_client_snd_openal.c
new file mode 100644
index 000000000000..a5151f4fc424
--- /dev/null
+++ b/games/tremulous/files/patch-src_client_snd_openal.c
@@ -0,0 +1,11 @@
+--- ./tremulous-1.1.0-src/src/client/snd_openal.c.orig 2009-12-26 18:56:43.000000000 +0100
++++ ./tremulous-1.1.0-src/src/client/snd_openal.c 2009-12-26 18:56:49.000000000 +0100
+@@ -1526,7 +1526,7 @@
+ #ifdef _WIN32
+ #define ALDRIVER_DEFAULT "OpenAL32.dll"
+ #else
+-#define ALDRIVER_DEFAULT "libopenal.so.0"
++#define ALDRIVER_DEFAULT "libopenal.so"
+ #endif
+
+ /*