aboutsummaryrefslogtreecommitdiffstats
path: root/games/ttraffic
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-07-26 13:33:51 +0800
committeraz <az@FreeBSD.org>2013-07-26 13:33:51 +0800
commitc1e6f9b1282b29ade869dbab3f1768fbcc2443a6 (patch)
treeeb22256c13100460a384a64ae5d3fbefbaab9ab7 /games/ttraffic
parentd52530844c122dbe12c5c32217f4ffdae83fe830 (diff)
downloadfreebsd-ports-gnome-c1e6f9b1282b29ade869dbab3f1768fbcc2443a6.tar.gz
freebsd-ports-gnome-c1e6f9b1282b29ade869dbab3f1768fbcc2443a6.tar.zst
freebsd-ports-gnome-c1e6f9b1282b29ade869dbab3f1768fbcc2443a6.zip
- switch simple inline replacement from perl to sed
and remove where is no need in this anymore. - trim Makefile header Approved by: bapt@ (portmrg@)
Diffstat (limited to 'games/ttraffic')
-rw-r--r--games/ttraffic/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/games/ttraffic/Makefile b/games/ttraffic/Makefile
index a73656558e67..dcb9b0b93253 100644
--- a/games/ttraffic/Makefile
+++ b/games/ttraffic/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: games/ttraffic
-# Date created: 14 November 2001
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= ttraffic
PORTVERSION= 0.8
@@ -20,11 +16,16 @@ RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
NO_BUILD= yes
USE_PERL5_BUILD=yes
+USES= shebangfix
+SHEBANG_FILES= ttraffic.tcl
+SHEBANG_LANG= wish
+wish_OLD_CMD= /usr/bin/wish
+wish_CMD= ${LOCALBASE}/bin/wish8.4
post-patch:
- ${PERL} -pi -e 's|/usr/local/share/ttraffic/|${DATADIR}/|g;' \
- -e 's|#!/usr/bin/wish|#!${LOCALBASE}/bin/wish8.4|g' \
+ @${REINPLACE_CMD} -i '' -e 's|/usr/local/share/ttraffic/|${DATADIR}/|' \
${WRKSRC}/ttraffic.tcl
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/ttraffic.tcl ${PREFIX}/bin/ttraffic
${MKDIR} ${DATADIR}