aboutsummaryrefslogtreecommitdiffstats
path: root/games/tuxmath/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-07-21 00:01:36 +0800
committerpav <pav@FreeBSD.org>2005-07-21 00:01:36 +0800
commit5b8ffecefe68916cb0d50ea32037694edf1c8709 (patch)
tree561e44679e9d3beff185d1f266d5c5de141fe6d1 /games/tuxmath/Makefile
parent12da3cab52dd1ed6ab0451a9ac83dad25fdc23b5 (diff)
downloadfreebsd-ports-gnome-5b8ffecefe68916cb0d50ea32037694edf1c8709.tar.gz
freebsd-ports-gnome-5b8ffecefe68916cb0d50ea32037694edf1c8709.tar.zst
freebsd-ports-gnome-5b8ffecefe68916cb0d50ea32037694edf1c8709.zip
"Tux, of Math Command" ("TuxMath," for short) is an educational arcade game
starring Tux, the Linux mascot! Based on the classic arcade game "Missile Command," Tux must defend his cities. In this case, though, he must do it by solving math problems. PR: ports/83747 Submitted by: Alejandro Pulver <alejandro@varnet.biz>
Diffstat (limited to 'games/tuxmath/Makefile')
-rw-r--r--games/tuxmath/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/games/tuxmath/Makefile b/games/tuxmath/Makefile
new file mode 100644
index 000000000000..155487b42252
--- /dev/null
+++ b/games/tuxmath/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: tuxmath
+# Date created: 14 Jul 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tuxmath
+DISTVERSION= 2001.09.07-0102
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Educational arcade game starring Tux
+
+USE_GMAKE= yes
+USE_SDL= image mixer sdl
+USE_REINPLACE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-extract:
+# Remove CVS and .xvpics directories
+.for d in CVS .xvpics
+ @${FIND} ${WRKSRC} -type d -name ${d} -print0 | \
+ ${XARGS} -0 ${RM} -rf
+.endfor
+
+post-install:
+# Fix permissions
+ @${CHOWN} -R ${BINOWN}:${BINGRP} ${DATADIR}
+ @${FIND} ${DATADIR} -type f -print0 | \
+ ${XARGS} -0 ${CHMOD} 644
+ @${FIND} ${DATADIR} -type d -print0 | \
+ ${XARGS} -0 ${CHMOD} 755
+
+post-patch:
+# Fix Makefile
+ @${REINPLACE_CMD} -e 's|/usr/share/tuxmath|${DATADIR}| ; \
+ s|\(BIN_PREFIX=\).*|\1${PREFIX}/bin/| ; \
+ s|sdl-config|${SDL_CONFIG}|' \
+ ${WRKSRC}/${MAKEFILE}
+
+.include <bsd.port.mk>