aboutsummaryrefslogtreecommitdiffstats
path: root/games/tuxmath
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-13 00:35:45 +0800
committerbapt <bapt@FreeBSD.org>2012-06-13 00:35:45 +0800
commitb0ad879e3e23b8ba6d75396d593d1bba436ffed6 (patch)
tree8b078441d20301eb3b13f3b6b3a374c4688468a4 /games/tuxmath
parent624c78988bf68a8f633b795635f8ba4b2fffed13 (diff)
downloadfreebsd-ports-gnome-b0ad879e3e23b8ba6d75396d593d1bba436ffed6.tar.gz
freebsd-ports-gnome-b0ad879e3e23b8ba6d75396d593d1bba436ffed6.tar.zst
freebsd-ports-gnome-b0ad879e3e23b8ba6d75396d593d1bba436ffed6.zip
Convert to new options framework
Diffstat (limited to 'games/tuxmath')
-rw-r--r--games/tuxmath/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/games/tuxmath/Makefile b/games/tuxmath/Makefile
index 9f392b41955f..89b6bad1debc 100644
--- a/games/tuxmath/Makefile
+++ b/games/tuxmath/Makefile
@@ -20,8 +20,8 @@ COMMENT= Educational arcade game starring Tux
LICENSE= GPLv3 # (or later)
-OPTIONS= NLS "Enable Native Language Support" on \
- RSVG "Enable libRSVG support" on
+OPTIONS_DEFINE= NLS SVG DOCS
+OPTIONS_DEFAULT= SVG
WRKSRC= ${WRKDIR}/${PORTNAME}_w_fonts-${PORTVERSION}
@@ -47,17 +47,17 @@ T4K_WRKSRC= ${WRKDIR}/${T4K_NAME}-${T4K_VERSION}
.include <bsd.port.options.mk>
-.if defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
+PLIST_SUB+= NLS=""
+.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
-.else
-PLIST_SUB+= NLS=""
.endif
-.if defined(WITHOUT_RSVG)
-CONFIGURE_ARGS+=--without-rsvg
-.else
+.if ${PORT_OPTIONS:MSVG}
USE_GNOME+= librsvg2
+.else
+CONFIGURE_ARGS+=--without-rsvg
.endif
# use multiple make jobs for T4K_WRKSRC
@@ -86,7 +86,7 @@ pre-build:
${MAKEFILE} ${_make_jobs} ${ALL_TARGET})
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in OFL README README_DATA_LICENSES TODO changelog
${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}