aboutsummaryrefslogtreecommitdiffstats
path: root/games/tuxmath
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-05-25 23:21:34 +0800
committermiwi <miwi@FreeBSD.org>2012-05-25 23:21:34 +0800
commitbf6f99a5e2201b9b9cba949d0f938599ba8bf730 (patch)
tree4ee9f9b8cb29f3f0d36bcc399be77c1427677214 /games/tuxmath
parent5b175667774002fdd44c21a8c0a88d55246de4a8 (diff)
downloadfreebsd-ports-gnome-bf6f99a5e2201b9b9cba949d0f938599ba8bf730.tar.gz
freebsd-ports-gnome-bf6f99a5e2201b9b9cba949d0f938599ba8bf730.tar.zst
freebsd-ports-gnome-bf6f99a5e2201b9b9cba949d0f938599ba8bf730.zip
- Update to 2.0.3
PR: 168034 Submitted by: Ports Fury
Diffstat (limited to 'games/tuxmath')
-rw-r--r--games/tuxmath/Makefile79
-rw-r--r--games/tuxmath/distinfo6
-rw-r--r--games/tuxmath/pkg-plist309
3 files changed, 340 insertions, 54 deletions
diff --git a/games/tuxmath/Makefile b/games/tuxmath/Makefile
index 4ca14e891f08..407c0806f39f 100644
--- a/games/tuxmath/Makefile
+++ b/games/tuxmath/Makefile
@@ -6,25 +6,45 @@
#
PORTNAME= tuxmath
-PORTVERSION= 1.6.0
-PORTREVISION= 7
+PORTVERSION= 2.0.3
PORTEPOCH= 1
CATEGORIES= games
-MASTER_SITES= http://alioth.debian.org/frs/download.php/2191/
-DISTNAME= ${PORTNAME}_w_fonts-${PORTVERSION}
+MASTER_SITES= http://alioth.debian.org/frs/download.php/3571/ \
+ http://alioth.debian.org/frs/download.php/3540/:t4k_common
+DISTFILES= ${PORTNAME}_w_fonts-${PORTVERSION}${EXTRACT_SUFX} \
+ ${T4K_DISTFILE}:t4k_common
MAINTAINER= ports@FreeBSD.org
COMMENT= Educational arcade game starring Tux
+LICENSE= GPLv3 # (or later)
+
+OPTIONS= NLS "Enable Native Language Support" on \
+ RSVG "Enable libRSVG support" on
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_w_fonts-${PORTVERSION}
+
+USE_GNOME= libxml2
+USE_SDL= image mixer net pango sdl
+USE_PERL5= yes
+USE_ICONV= yes
USE_GMAKE= yes
-USE_SDL= image mixer sdl ttf
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --program-transform-name=""
-WRKSRC= ${WRKDIR}/${DISTNAME:S/${PORTVERSION}/1.5.8/}
+CONFIGURE_ENV= T4K_COMMON_CFLAGS="-I${T4K_WRKSRC}/src" \
+ T4K_COMMON_LIBS="${T4K_WRKSRC}/src/.libs/libt4k_common.a" \
+ ac_cv_lib_m_csin=yes
+MAKE_JOBS_SAFE= yes
+
+CPPFLAGS+= $$(pkg-config --cflags SDL_Pango) -I${LOCALBASE}/include \
+ -DHAVE_ALPHASORT -DHAVE_SCANDIR -DHAVE_FSYNC -DICONV_CONST=""
+LDFLAGS+= $$(pkg-config --libs SDL_Pango) -L${LOCALBASE}/lib
-OPTIONS= NLS "Enable Native Language Support" on
+T4K_NAME= t4k_common
+T4K_VERSION= 0.1.1
+T4K_DISTFILE= ${T4K_NAME}-${T4K_VERSION}${EXTRACT_SUFX}
+T4K_WRKSRC= ${WRKDIR}/${T4K_NAME}-${T4K_VERSION}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+=--disable-nls
@@ -33,8 +53,43 @@ PLIST_SUB+= NLS="@comment "
PLIST_SUB+= NLS=""
.endif
+.if defined(WITHOUT_RSVG)
+CONFIGURE_ARGS+=--without-rsvg
+.else
+USE_GNOME+= librsvg2
+.endif
+
+# use multiple make jobs for T4K_WRKSRC
+.if !defined(DISABLE_MAKE_JOBS)
+_make_jobs= -j${MAKE_JOBS_NUMBER}
+.endif
+
+post-extract:
+ @${LN} -sf ${T4K_WRKSRC} ${WRKDIR}/${T4K_NAME}
+
post-patch:
- @${REINPLACE_CMD} -e 's|$$(prefix)/doc/$$(PACKAGE)|$$(docdir)|' \
- ${WRKSRC}/docs/Makefile.in
+ @${REINPLACE_CMD} -e \
+ '/doc[[:space:]]/d' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|-Wall -g |-Wall | ; \
+ s|-DDEBUG ||' ${WRKSRC}/src/Makefile.in
+
+pre-configure:
+ @(cd ${T4K_WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./configure \
+ --disable-shared ${CONFIGURE_ARGS} CC="${CC}" CXX="${CXX}" \
+ CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}")
+
+pre-build:
+ @(cd ${T4K_WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${_make_jobs} ${ALL_TARGET})
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in OFL README README_DATA_LICENSES TODO changelog
+ ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
+.endfor
+.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/tuxmath/distinfo b/games/tuxmath/distinfo
index 9cfc43238a68..6aaccd5118dc 100644
--- a/games/tuxmath/distinfo
+++ b/games/tuxmath/distinfo
@@ -1,2 +1,4 @@
-SHA256 (tuxmath_w_fonts-1.6.0.tar.gz) = 56050037f16e6f24e41a9613fc3d7365ddaf42036a5dbc5a6be2fc33c6c1ee89
-SIZE (tuxmath_w_fonts-1.6.0.tar.gz) = 4651140
+SHA256 (tuxmath_w_fonts-2.0.3.tar.gz) = eec49c296d41df39a6474d94ba4e3334e4c16dc180d3ea4a6defc2debfc39887
+SIZE (tuxmath_w_fonts-2.0.3.tar.gz) = 10396696
+SHA256 (t4k_common-0.1.1.tar.gz) = 42c155816dae2c5dad560faa50edaa1ca84536530283d37859c4b91e82675110
+SIZE (t4k_common-0.1.1.tar.gz) = 629215
diff --git a/games/tuxmath/pkg-plist b/games/tuxmath/pkg-plist
index b44aad99e437..e5985621d027 100644
--- a/games/tuxmath/pkg-plist
+++ b/games/tuxmath/pkg-plist
@@ -1,9 +1,53 @@
+bin/generate_lesson
bin/tuxmath
+bin/tuxmathadmin
+bin/tuxmathserver
+bin/tuxmathtestclient
+%%PORTDOCS%%%%DOCSDIR%%/OFL
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README_DATA_LICENSES
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/changelog
+%%NLS%%share/locale/ar/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/ast/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/tuxmath.mo
%%NLS%%share/locale/cs/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/da/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/de/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/el/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/en@boldquot/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/en@quot/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/es/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/he/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/hi/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/it/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/ku/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/mn/LC_MESSAGES/tuxmath.mo
%%NLS%%share/locale/nb/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/tuxmath.mo
%%NLS%%share/locale/nn/LC_MESSAGES/tuxmath.mo
-%%NLS%%share/locale/en@quot/LC_MESSAGES/tuxmath.mo
-%%NLS%%share/locale/en@boldquot/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/oc/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/tl/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/zam/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/tuxmath.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/tuxmath.mo
%%DATADIR%%/fonts/AndikaDesRevG.ttf
%%DATADIR%%/images/backgrounds/0.jpg
%%DATADIR%%/images/backgrounds/1.jpg
@@ -13,61 +57,108 @@ bin/tuxmath
%%DATADIR%%/images/backgrounds/5.jpg
%%DATADIR%%/images/backgrounds/6.jpg
%%DATADIR%%/images/backgrounds/7.jpg
-%%DATADIR%%/images/backgrounds/8.jpg
-%%DATADIR%%/images/backgrounds/9.jpg
-%%DATADIR%%/images/backgrounds/10.jpg
-%%DATADIR%%/images/backgrounds/11.jpg
-%%DATADIR%%/images/backgrounds/12.jpg
-%%DATADIR%%/images/cities/city-blue.png
%%DATADIR%%/images/cities/cdead-blue.png
+%%DATADIR%%/images/cities/cdead-green.png
+%%DATADIR%%/images/cities/cdead-orange.png
+%%DATADIR%%/images/cities/cdead-red.png
+%%DATADIR%%/images/cities/city-blue.png
+%%DATADIR%%/images/cities/city-green.png
+%%DATADIR%%/images/cities/city-orange.png
+%%DATADIR%%/images/cities/city-red.png
%%DATADIR%%/images/cities/csplode-blue-1.png
%%DATADIR%%/images/cities/csplode-blue-2.png
%%DATADIR%%/images/cities/csplode-blue-3.png
%%DATADIR%%/images/cities/csplode-blue-4.png
%%DATADIR%%/images/cities/csplode-blue-5.png
-%%DATADIR%%/images/cities/city-green.png
-%%DATADIR%%/images/cities/cdead-green.png
%%DATADIR%%/images/cities/csplode-green-1.png
%%DATADIR%%/images/cities/csplode-green-2.png
%%DATADIR%%/images/cities/csplode-green-3.png
%%DATADIR%%/images/cities/csplode-green-4.png
%%DATADIR%%/images/cities/csplode-green-5.png
-%%DATADIR%%/images/cities/city-orange.png
-%%DATADIR%%/images/cities/cdead-orange.png
%%DATADIR%%/images/cities/csplode-orange-1.png
-%%DATADIR%%/images/cities/city-red.png
%%DATADIR%%/images/cities/csplode-orange-2.png
%%DATADIR%%/images/cities/csplode-orange-3.png
%%DATADIR%%/images/cities/csplode-orange-4.png
%%DATADIR%%/images/cities/csplode-orange-5.png
-%%DATADIR%%/images/cities/cdead-red.png
%%DATADIR%%/images/cities/csplode-red-1.png
%%DATADIR%%/images/cities/csplode-red-2.png
%%DATADIR%%/images/cities/csplode-red-3.png
%%DATADIR%%/images/cities/csplode-red-4.png
%%DATADIR%%/images/cities/csplode-red-5.png
%%DATADIR%%/images/cities/shields.png
+%%DATADIR%%/images/comets/bonus_comet.svg
+%%DATADIR%%/images/comets/bonus_comet0.png
%%DATADIR%%/images/comets/bonus_comet1.png
%%DATADIR%%/images/comets/bonus_comet2.png
-%%DATADIR%%/images/comets/bonus_comet3.png
-%%DATADIR%%/images/comets/bonus_cometex1a.png
+%%DATADIR%%/images/comets/bonus_cometex.svg
+%%DATADIR%%/images/comets/bonus_cometex0.png
%%DATADIR%%/images/comets/bonus_cometex1.png
%%DATADIR%%/images/comets/bonus_cometex2.png
%%DATADIR%%/images/comets/bonus_cometex3.png
+%%DATADIR%%/images/comets/comet.svg
+%%DATADIR%%/images/comets/comet0.png
%%DATADIR%%/images/comets/comet1.png
%%DATADIR%%/images/comets/comet2.png
-%%DATADIR%%/images/comets/comet3.png
-%%DATADIR%%/images/comets/cometex1a.png
+%%DATADIR%%/images/comets/cometex.svg
+%%DATADIR%%/images/comets/cometex0.png
%%DATADIR%%/images/comets/cometex1.png
%%DATADIR%%/images/comets/cometex2.png
%%DATADIR%%/images/comets/cometex3.png
+%%DATADIR%%/images/comets/left_powerup_comet.svg
+%%DATADIR%%/images/comets/left_powerup_comet0.png
+%%DATADIR%%/images/comets/left_powerup_comet1.png
+%%DATADIR%%/images/comets/left_powerup_comet2.png
+%%DATADIR%%/images/comets/left_powerup_cometd.png
%%DATADIR%%/images/comets/mini_comet1.png
%%DATADIR%%/images/comets/mini_comet2.png
%%DATADIR%%/images/comets/mini_comet3.png
-%%DATADIR%%/images/icons/tuxmath.ico
+%%DATADIR%%/images/comets/powerup_cometex.svg
+%%DATADIR%%/images/comets/powerup_cometex0.png
+%%DATADIR%%/images/comets/powerup_cometex1.png
+%%DATADIR%%/images/comets/powerup_cometex2.png
+%%DATADIR%%/images/comets/powerup_cometex3.png
+%%DATADIR%%/images/comets/powerup_cometexd.png
+%%DATADIR%%/images/comets/right_powerup_comet.svg
+%%DATADIR%%/images/comets/right_powerup_comet0.png
+%%DATADIR%%/images/comets/right_powerup_comet1.png
+%%DATADIR%%/images/comets/right_powerup_comet2.png
+%%DATADIR%%/images/comets/right_powerup_cometd.png
+%%DATADIR%%/images/factoroids/asteroid1.png
+%%DATADIR%%/images/factoroids/asteroid2.png
+%%DATADIR%%/images/factoroids/asteroid3.png
+%%DATADIR%%/images/factoroids/button_11.png
+%%DATADIR%%/images/factoroids/button_13.png
+%%DATADIR%%/images/factoroids/button_2.png
+%%DATADIR%%/images/factoroids/button_3.png
+%%DATADIR%%/images/factoroids/button_5.png
+%%DATADIR%%/images/factoroids/button_7.png
+%%DATADIR%%/images/factoroids/cockpit.png
+%%DATADIR%%/images/factoroids/factoroids.png
+%%DATADIR%%/images/factoroids/factors.png
+%%DATADIR%%/images/factoroids/forcefield.png
+%%DATADIR%%/images/factoroids/galaxy1.png
+%%DATADIR%%/images/factoroids/galaxy2.png
+%%DATADIR%%/images/factoroids/gbstars.png
+%%DATADIR%%/images/factoroids/good.png
+%%DATADIR%%/images/factoroids/powerbomb.png
+%%DATADIR%%/images/factoroids/shield.png
+%%DATADIR%%/images/factoroids/ship-cloaked.png
+%%DATADIR%%/images/factoroids/ship-thrust-cloaked.png
+%%DATADIR%%/images/factoroids/ship-thrust.png
+%%DATADIR%%/images/factoroids/ship.png
+%%DATADIR%%/images/factoroids/star1.jpg
+%%DATADIR%%/images/factoroids/star1.png
+%%DATADIR%%/images/factoroids/star2.png
+%%DATADIR%%/images/factoroids/star3.png
+%%DATADIR%%/images/factoroids/star4.png
+%%DATADIR%%/images/factoroids/star5.png
+%%DATADIR%%/images/factoroids/stealth.png
+%%DATADIR%%/images/factoroids/tux.png
%%DATADIR%%/images/icons/icon.png
%%DATADIR%%/images/icons/icon.xpm
%%DATADIR%%/images/icons/tuxmath.icns
+%%DATADIR%%/images/icons/tuxmath.ico
+%%DATADIR%%/images/icons/tuxmath.svg
%%DATADIR%%/images/igloos/cloud.png
%%DATADIR%%/images/igloos/composite.svg
%%DATADIR%%/images/igloos/extra_life.png
@@ -99,6 +190,10 @@ bin/tuxmath
%%DATADIR%%/images/penguins/walk-on2.png
%%DATADIR%%/images/penguins/walk-on3.png
%%DATADIR%%/images/penguins/worried.png
+%%DATADIR%%/images/sprites/alone.svg
+%%DATADIR%%/images/sprites/alone0.png
+%%DATADIR%%/images/sprites/alone1.png
+%%DATADIR%%/images/sprites/aloned.png
%%DATADIR%%/images/sprites/comet0.png
%%DATADIR%%/images/sprites/comet1.png
%%DATADIR%%/images/sprites/comet2.png
@@ -111,19 +206,56 @@ bin/tuxmath
%%DATADIR%%/images/sprites/credits2.png
%%DATADIR%%/images/sprites/credits3.png
%%DATADIR%%/images/sprites/creditsd.png
-%%DATADIR%%/images/sprites/goldstard.png
+%%DATADIR%%/images/sprites/exclamation.svg
+%%DATADIR%%/images/sprites/exclamation0.png
+%%DATADIR%%/images/sprites/exclamationd.png
+%%DATADIR%%/images/sprites/factoroids.svg
+%%DATADIR%%/images/sprites/factoroids0.png
+%%DATADIR%%/images/sprites/factoroids1.png
+%%DATADIR%%/images/sprites/factoroids2.png
+%%DATADIR%%/images/sprites/factoroidsd.png
+%%DATADIR%%/images/sprites/factors0.png
+%%DATADIR%%/images/sprites/factors1.png
+%%DATADIR%%/images/sprites/factors2.png
+%%DATADIR%%/images/sprites/factors3.png
+%%DATADIR%%/images/sprites/factors4.png
+%%DATADIR%%/images/sprites/factors5.png
+%%DATADIR%%/images/sprites/factorsd.png
+%%DATADIR%%/images/sprites/fleet.svg
+%%DATADIR%%/images/sprites/fleet0.png
+%%DATADIR%%/images/sprites/fleetd.png
+%%DATADIR%%/images/sprites/fractions0.png
+%%DATADIR%%/images/sprites/fractions1.png
+%%DATADIR%%/images/sprites/fractions2.png
+%%DATADIR%%/images/sprites/fractions3.png
+%%DATADIR%%/images/sprites/fractions4.png
+%%DATADIR%%/images/sprites/fractions5.png
+%%DATADIR%%/images/sprites/fractions6.png
+%%DATADIR%%/images/sprites/fractionsd.png
+%%DATADIR%%/images/sprites/friends.svg
+%%DATADIR%%/images/sprites/friends0.png
+%%DATADIR%%/images/sprites/friendsd.png
+%%DATADIR%%/images/sprites/goldstar.svg
%%DATADIR%%/images/sprites/goldstar0.png
%%DATADIR%%/images/sprites/goldstar1.png
+%%DATADIR%%/images/sprites/goldstard.png
+%%DATADIR%%/images/sprites/help.svg
%%DATADIR%%/images/sprites/help0.png
%%DATADIR%%/images/sprites/help1.png
%%DATADIR%%/images/sprites/help2.png
%%DATADIR%%/images/sprites/help3.png
%%DATADIR%%/images/sprites/helpd.png
+%%DATADIR%%/images/sprites/lan.svg
+%%DATADIR%%/images/sprites/lan0.png
+%%DATADIR%%/images/sprites/lan1.png
+%%DATADIR%%/images/sprites/land.png
+%%DATADIR%%/images/sprites/lesson.svg
%%DATADIR%%/images/sprites/lesson0.png
%%DATADIR%%/images/sprites/lesson1.png
%%DATADIR%%/images/sprites/lesson2.png
%%DATADIR%%/images/sprites/lesson3.png
%%DATADIR%%/images/sprites/lessond.png
+%%DATADIR%%/images/sprites/main.svg
%%DATADIR%%/images/sprites/main0.png
%%DATADIR%%/images/sprites/main1.png
%%DATADIR%%/images/sprites/main2.png
@@ -133,9 +265,21 @@ bin/tuxmath
%%DATADIR%%/images/sprites/main6.png
%%DATADIR%%/images/sprites/main7.png
%%DATADIR%%/images/sprites/maind.png
-%%DATADIR%%/images/sprites/quit0.png
-%%DATADIR%%/images/sprites/no_goldstard.png
+%%DATADIR%%/images/sprites/no_goldstar.svg
%%DATADIR%%/images/sprites/no_goldstar0.png
+%%DATADIR%%/images/sprites/no_goldstard.png
+%%DATADIR%%/images/sprites/nums.svg
+%%DATADIR%%/images/sprites/nums0.png
+%%DATADIR%%/images/sprites/nums1.png
+%%DATADIR%%/images/sprites/nums2.png
+%%DATADIR%%/images/sprites/nums3.png
+%%DATADIR%%/images/sprites/nums4.png
+%%DATADIR%%/images/sprites/nums5.png
+%%DATADIR%%/images/sprites/nums6.png
+%%DATADIR%%/images/sprites/nums7.png
+%%DATADIR%%/images/sprites/numsd.png
+%%DATADIR%%/images/sprites/quit.svg
+%%DATADIR%%/images/sprites/quit0.png
%%DATADIR%%/images/sprites/quit1.png
%%DATADIR%%/images/sprites/quit2.png
%%DATADIR%%/images/sprites/quit3.png
@@ -148,12 +292,21 @@ bin/tuxmath
%%DATADIR%%/images/sprites/trophy0.png
%%DATADIR%%/images/sprites/trophy1.png
%%DATADIR%%/images/sprites/trophyd.png
+%%DATADIR%%/images/sprites/tux_config.svg
%%DATADIR%%/images/sprites/tux_config0.png
%%DATADIR%%/images/sprites/tux_config1.png
+%%DATADIR%%/images/sprites/tux_config_brown.svg
%%DATADIR%%/images/sprites/tux_config_brown0.png
%%DATADIR%%/images/sprites/tux_config_brown1.png
%%DATADIR%%/images/sprites/tux_config_brownd.png
%%DATADIR%%/images/sprites/tux_configd.png
+%%DATADIR%%/images/sprites/tux_helmet0.png
+%%DATADIR%%/images/sprites/tux_helmet1.png
+%%DATADIR%%/images/sprites/tux_helmet2.png
+%%DATADIR%%/images/sprites/tux_helmet_black.svg
+%%DATADIR%%/images/sprites/tux_helmet_black0.png
+%%DATADIR%%/images/sprites/tux_helmet_blackd.png
+%%DATADIR%%/images/sprites/tux_helmet_blue.svg
%%DATADIR%%/images/sprites/tux_helmet_blue0.png
%%DATADIR%%/images/sprites/tux_helmet_blue1.png
%%DATADIR%%/images/sprites/tux_helmet_blue2.png
@@ -161,20 +314,23 @@ bin/tuxmath
%%DATADIR%%/images/sprites/tux_helmet_blue4.png
%%DATADIR%%/images/sprites/tux_helmet_blue5.png
%%DATADIR%%/images/sprites/tux_helmet_blued.png
+%%DATADIR%%/images/sprites/tux_helmet_green.svg
%%DATADIR%%/images/sprites/tux_helmet_green0.png
-%%DATADIR%%/images/sprites/tux_helmet_red0.png
%%DATADIR%%/images/sprites/tux_helmet_green1.png
%%DATADIR%%/images/sprites/tux_helmet_green2.png
%%DATADIR%%/images/sprites/tux_helmet_green3.png
%%DATADIR%%/images/sprites/tux_helmet_green4.png
%%DATADIR%%/images/sprites/tux_helmet_green5.png
%%DATADIR%%/images/sprites/tux_helmet_greend.png
+%%DATADIR%%/images/sprites/tux_helmet_red.svg
+%%DATADIR%%/images/sprites/tux_helmet_red0.png
%%DATADIR%%/images/sprites/tux_helmet_red1.png
%%DATADIR%%/images/sprites/tux_helmet_red2.png
%%DATADIR%%/images/sprites/tux_helmet_red3.png
%%DATADIR%%/images/sprites/tux_helmet_red4.png
%%DATADIR%%/images/sprites/tux_helmet_red5.png
%%DATADIR%%/images/sprites/tux_helmet_redd.png
+%%DATADIR%%/images/sprites/tux_helmet_yellow.svg
%%DATADIR%%/images/sprites/tux_helmet_yellow0.png
%%DATADIR%%/images/sprites/tux_helmet_yellow1.png
%%DATADIR%%/images/sprites/tux_helmet_yellow2.png
@@ -182,37 +338,67 @@ bin/tuxmath
%%DATADIR%%/images/sprites/tux_helmet_yellow4.png
%%DATADIR%%/images/sprites/tux_helmet_yellow5.png
%%DATADIR%%/images/sprites/tux_helmet_yellowd.png
-%%DATADIR%%/images/status/demo.png
+%%DATADIR%%/images/sprites/tux_helmetd.png
+%%DATADIR%%/images/status/arrows.png
%%DATADIR%%/images/status/demo-small.png
+%%DATADIR%%/images/status/demo.png
%%DATADIR%%/images/status/gameover.png
%%DATADIR%%/images/status/gameover_won.png
-%%DATADIR%%/images/status/keypad_no_neg.png
%%DATADIR%%/images/status/keypad.png
+%%DATADIR%%/images/status/keypad_no_neg.png
%%DATADIR%%/images/status/led_neg_sign.png
%%DATADIR%%/images/status/lednums.png
-%%DATADIR%%/images/status/left_gray.png
%%DATADIR%%/images/status/left.png
+%%DATADIR%%/images/status/left.svg
+%%DATADIR%%/images/status/left_gray.png
+%%DATADIR%%/images/status/left_gray.svg
%%DATADIR%%/images/status/loading.png
%%DATADIR%%/images/status/nbs.png
%%DATADIR%%/images/status/numbers.png
%%DATADIR%%/images/status/nums.png
%%DATADIR%%/images/status/paused.png
-%%DATADIR%%/images/status/right_gray.png
+%%DATADIR%%/images/status/player_pause.svg
+%%DATADIR%%/images/status/player_play.svg
%%DATADIR%%/images/status/right.png
+%%DATADIR%%/images/status/right.svg
+%%DATADIR%%/images/status/right_gray.png
+%%DATADIR%%/images/status/right_gray.svg
%%DATADIR%%/images/status/score.png
%%DATADIR%%/images/status/standby.png
%%DATADIR%%/images/status/stop.png
+%%DATADIR%%/images/status/stop.svg
%%DATADIR%%/images/status/title.png
%%DATADIR%%/images/status/tux4kids.png
+%%DATADIR%%/images/status/tux4kids.svg
%%DATADIR%%/images/status/wave.png
+%%DATADIR%%/images/title/egg.png
+%%DATADIR%%/images/title/egg.svg
%%DATADIR%%/images/title/menu_bkg.jpg
%%DATADIR%%/images/title/title1.png
+%%DATADIR%%/images/title/title1.svg
+%%DATADIR%%/images/tux/bigtux.svg
%%DATADIR%%/images/tux/bigtux0.png
+%%DATADIR%%/images/tux/bigtux0.svg
%%DATADIR%%/images/tux/bigtux1.png
+%%DATADIR%%/images/tux/bigtux1.svg
%%DATADIR%%/images/tux/bigtux2.png
+%%DATADIR%%/images/tux/bigtux2.svg
%%DATADIR%%/images/tux/bigtux3.png
-%%DATADIR%%/images/tux/console_led.png
+%%DATADIR%%/images/tux/bigtux3.svg
+%%DATADIR%%/images/tux/bigtux4.png
+%%DATADIR%%/images/tux/bigtux4.svg
+%%DATADIR%%/images/tux/bigtux5.png
+%%DATADIR%%/images/tux/bigtux5.svg
+%%DATADIR%%/images/tux/bigtux6.png
+%%DATADIR%%/images/tux/bigtux6.svg
+%%DATADIR%%/images/tux/cockpit_tux1.png
+%%DATADIR%%/images/tux/cockpit_tux2.png
+%%DATADIR%%/images/tux/cockpit_tux3.png
+%%DATADIR%%/images/tux/cockpit_tux4.png
+%%DATADIR%%/images/tux/cockpit_tux5.png
+%%DATADIR%%/images/tux/cockpit_tux6.png
%%DATADIR%%/images/tux/console_bash.png
+%%DATADIR%%/images/tux/console_led.png
%%DATADIR%%/images/tux/tux-console1.png
%%DATADIR%%/images/tux/tux-console2.png
%%DATADIR%%/images/tux/tux-console3.png
@@ -234,10 +420,38 @@ bin/tuxmath
%%DATADIR%%/images/tux/tux-yes1.png
%%DATADIR%%/images/tux/tux-yes2.png
%%DATADIR%%/images/tux/tux-yipe.png
+%%DATADIR%%/menus/main_menu.xml
%%DATADIR%%/missions/arcade/ace
+%%DATADIR%%/missions/arcade/commando
%%DATADIR%%/missions/arcade/ranger
%%DATADIR%%/missions/arcade/scout
%%DATADIR%%/missions/arcade/space_cadet
+%%DATADIR%%/missions/campaign/ace/ace
+%%DATADIR%%/missions/campaign/ace/bonus
+%%DATADIR%%/missions/campaign/ace/round1
+%%DATADIR%%/missions/campaign/ace/round2
+%%DATADIR%%/missions/campaign/ace/round3
+%%DATADIR%%/missions/campaign/cadet/bonus
+%%DATADIR%%/missions/campaign/cadet/cadet
+%%DATADIR%%/missions/campaign/cadet/round1
+%%DATADIR%%/missions/campaign/cadet/round2
+%%DATADIR%%/missions/campaign/cadet/round3
+%%DATADIR%%/missions/campaign/campaign
+%%DATADIR%%/missions/campaign/commando/commando
+%%DATADIR%%/missions/campaign/commando/round1
+%%DATADIR%%/missions/campaign/commando/round2
+%%DATADIR%%/missions/campaign/commando/round3
+%%DATADIR%%/missions/campaign/ranger/bonus
+%%DATADIR%%/missions/campaign/ranger/ranger
+%%DATADIR%%/missions/campaign/ranger/round1
+%%DATADIR%%/missions/campaign/ranger/round2
+%%DATADIR%%/missions/campaign/ranger/round3
+%%DATADIR%%/missions/campaign/scout/bonus
+%%DATADIR%%/missions/campaign/scout/round1
+%%DATADIR%%/missions/campaign/scout/round2
+%%DATADIR%%/missions/campaign/scout/round3
+%%DATADIR%%/missions/campaign/scout/scout
+%%DATADIR%%/missions/demo
%%DATADIR%%/missions/lessons/lesson00
%%DATADIR%%/missions/lessons/lesson01
%%DATADIR%%/missions/lessons/lesson02
@@ -247,7 +461,6 @@ bin/tuxmath
%%DATADIR%%/missions/lessons/lesson06
%%DATADIR%%/missions/lessons/lesson07
%%DATADIR%%/missions/lessons/lesson08
-%%DATADIR%%/missions/lessons/lesson08.1
%%DATADIR%%/missions/lessons/lesson09
%%DATADIR%%/missions/lessons/lesson10
%%DATADIR%%/missions/lessons/lesson11
@@ -294,16 +507,28 @@ bin/tuxmath
%%DATADIR%%/missions/lessons/lesson52
%%DATADIR%%/missions/lessons/lesson53
%%DATADIR%%/missions/lessons/lesson54
-%%DATADIR%%/missions/demo
+%%DATADIR%%/missions/lessons/lesson55
+%%DATADIR%%/missions/lessons/lesson56
+%%DATADIR%%/missions/lessons/lesson57
+%%DATADIR%%/missions/multiplay/ace
+%%DATADIR%%/missions/multiplay/commando
+%%DATADIR%%/missions/multiplay/mpoptions
+%%DATADIR%%/missions/multiplay/ranger
+%%DATADIR%%/missions/multiplay/scout
+%%DATADIR%%/missions/multiplay/space_cadet
%%DATADIR%%/missions/options
+%%DATADIR%%/sounds/01_rush.ogg
+%%DATADIR%%/sounds/02_on_the_edge_of_the_universe.ogg
+%%DATADIR%%/sounds/03_gravity.ogg
%%DATADIR%%/sounds/alarm.wav
%%DATADIR%%/sounds/buzz.wav
%%DATADIR%%/sounds/cheer.wav
-%%DATADIR%%/sounds/click.wav
+%%DATADIR%%/sounds/engine.wav
%%DATADIR%%/sounds/explosion.wav
+%%DATADIR%%/sounds/game.mod
%%DATADIR%%/sounds/game2.mod
%%DATADIR%%/sounds/game3.mod
-%%DATADIR%%/sounds/game.mod
+%%DATADIR%%/sounds/harp.wav
%%DATADIR%%/sounds/laser.wav
%%DATADIR%%/sounds/pop.wav
%%DATADIR%%/sounds/shieldsdown.wav
@@ -311,22 +536,24 @@ bin/tuxmath
%%DATADIR%%/sounds/tock.wav
%%DATADIR%%/sounds/towerclock.wav
%%DATADIR%%/sounds/tuxi.ogg
-%%DOCSDIR%%/changelog
-%%DOCSDIR%%/COPYING.txt
-%%DOCSDIR%%/INSTALL.txt
-%%DOCSDIR%%/OFL.txt
-%%DOCSDIR%%/README_DATA_LICENSES.TXT
-%%DOCSDIR%%/README.txt
-%%DOCSDIR%%/TODO.txt
@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/missions/multiplay
@dirrm %%DATADIR%%/missions/lessons
+@dirrm %%DATADIR%%/missions/campaign/scout
+@dirrm %%DATADIR%%/missions/campaign/ranger
+@dirrm %%DATADIR%%/missions/campaign/commando
+@dirrm %%DATADIR%%/missions/campaign/cadet
+@dirrm %%DATADIR%%/missions/campaign/ace
+@dirrm %%DATADIR%%/missions/campaign
@dirrm %%DATADIR%%/missions/arcade
@dirrm %%DATADIR%%/missions
+@dirrm %%DATADIR%%/menus
@dirrm %%DATADIR%%/images/tux
@dirrm %%DATADIR%%/images/title
@dirrm %%DATADIR%%/images/status
@dirrm %%DATADIR%%/images/sprites
@dirrm %%DATADIR%%/images/penguins
+@dirrm %%DATADIR%%/images/factoroids
@dirrm %%DATADIR%%/images/igloos
@dirrm %%DATADIR%%/images/icons
@dirrm %%DATADIR%%/images/comets
@@ -335,4 +562,6 @@ bin/tuxmath
@dirrm %%DATADIR%%/images
@dirrm %%DATADIR%%/fonts
@dirrm %%DATADIR%%
-@dirrm %%DOCSDIR%%
+%%NLS%%@dirrmtry share/locale/zam/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/zam
+%%PORTDOCS%%@dirrm %%DOCSDIR%%